Why are my conditions NOT working properly now?

  • Profile Image
    harropdan
    Asked on January 03, 2011 at 05:52 AM

    Hi.

     

    I have set up a series of conditions based on what value/number is entered into the No. of bedroom/bathroom fields e.g. if you enter in "2" in the No. of Bedrooms field (under Accommodation Overview), then only the fields Bedroom 1 and Bedroom 2 (under Accommodation Details) should remain shown, and Bedroom 3-5 fields will be hidden.

     

    It was working to begin with, but now it no longer hides the last fields (i.e. Bedroom 5 and Bathroom 3), even if the no of rooms entered in less than 3 and 5 respectively.

     

    I am using "form collapse" and the Accommodation Overview and Accommodation Detail are split into two separate sections, so I suspect that might be causing the error (i.e. the input being in the 1st section and the output being in the 2nd section).

     

    However, like I said, when I tested it originally it was working perfectly - so not sure why it isn't now. Please help and thanks in advance.

     

    The link is here: 

     

    http://www.jotform.com/form/3635913760 

  • Profile Image
    aytekin
    Answered on January 03, 2011 at 08:43 AM

    So, it stopped working after you added FormCollapse? You should probably remove the FormCollapse field from the form and see if that's what causing the problem. 

  • Profile Image
    harropdan
    Answered on January 03, 2011 at 11:35 AM

    Hi Thanks.

     

    As above, it was working WHILE the Form Collapse was in place. Either way, just tried to see if it works with Form Collapse taken out, and makes no difference.

     

    The problem seems to be that it is only applying ONE condition e.g. when criteria field X=1 is satisfied, it should hide fields A, B and C (i.e. separate conditions) but it appears to be stopping after just hiding field A.