Thank You Page: Thank You Page doesn't show up.

  • Profile Image
    ahuerta
    Asked on March 20, 2017 at 06:39 PM

    When I complete this form, the thank you page does not show up. https://form.jotform.com/70736291374157 

  • Profile Image
    Chriistian
    Answered on March 20, 2017 at 10:59 PM

    I cloned the form you have provided (https://form.jotform.com/70736291374157 ) and submitted the form. I was able to replicate the issue. Even the default Thank You page is not showing up. Please give me some time to further check on this. I'll get back once I've found results.

    Regards.

     

     

  • Profile Image
    Chriistian
    Answered on March 20, 2017 at 11:21 PM

    As per further checking, I opened a cloned form in builder version 3 but the issue still occurs. I will report this issue to our backend team for checking. We will let you know in this thread if there are any updates.

    Regards.

     

     

  • Profile Image
    Scott
    Answered on March 21, 2017 at 06:57 AM

    Hey ahuerta,

    I've fixed your form and it should be able to redirect to the Thank You Page as intended.

    This was caused due to false URL paths for the Page & Form Background images. It looks like this was a clone of another form and upon the cloning process an error caused this issue. Here is a screenshot of what I'm referring to:

    I have deleted the broken images from the form and updated them with the proper URL sources. If you do not want to use these images on your form, you can easily delete them from the Design tab:

     

    Please let us know if you ever need anything else,

    Cheers!