Forms are not being displayed in my webpage

  • Profile Image
    kushki
    Asked on March 20, 2017 at 10:07 PM
  • Profile Image
    Ian
    Answered on March 21, 2017 at 03:08 AM

    I could not replicate the issue at my end. This is the screenshot of what I see at my end 

    Please try again, let us know if you still face any issue. 

     

  • Profile Image
    Ian
    Answered on March 21, 2017 at 03:08 AM

    Also let us know if you you can access the form at URL https://www.jotform.com/70648516600656

     

  • Profile Image
    Oswaldo
    Answered on March 21, 2017 at 01:09 PM

    Hi, the issue persists. The form still won't display at https://www.kushkipagos.com/pages/aplicacion-cuenta-kushki-colombia. I tried https://www.jotform.com/70648516600656 and the form works fine there. Any suggestion on what might be happening?

  • Profile Image
    kushki
    Answered on March 21, 2017 at 02:11 PM

    It seems like is a DNS configuration for our region because we are not able to open https://form.jotformz.com/jsform/70648516600656", we are located in Ecuador, is there a way in which you can generate more generic URL which can be solved and accessed from our region?. This might be happening for all our current forms. Thank you!

  • Profile Image
    Jan
    Answered on March 21, 2017 at 05:14 PM

    The link you provided is incorrect. It is a link from the embed script code. I opened your webpage and the form is showing properly.

    Please try to re-embed the form using the iFrame method. Here's a guide: https://www.jotform.com/help/148-Getting-the-form-iFrame-code.

    Here's the iFrame code:

    <iframe id="JotFormIFrame-70648516600656" onload="window.parent.scrollTo(0,0)" allowtransparency="true" src="https://form.jotform.com/70648516600656" frameborder="0" style="width:100%; height:17047px; border:none;" scrolling="no"> </iframe> <script type="text/javascript"> var ifr = document.getElementById("JotFormIFrame-70648516600656"); if(window.location.href && window.location.href.indexOf("?") > -1) { var get = window.location.href.substr(window.location.href.indexOf("?") + 1); if(ifr && get.length > 0) { var src = ifr.src; src = src.indexOf("?") > -1 ? src + "&" + get : src + "?" + get; ifr.src = src; } } window.handleIFrameMessage = function(e) { var args = e.data.split(":"); if (args.length > 2) { iframe = document.getElementById("JotFormIFrame-" + args[2]); } else { iframe = document.getElementById("JotFormIFrame"); } if (!iframe) return; switch (args[0]) { case "scrollIntoView": iframe.scrollIntoView(); break; case "setHeight": iframe.style.height = args[1] + "px"; break; case "collapseErrorPage": if (iframe.clientHeight > window.innerHeight) { iframe.style.height = window.innerHeight + "px"; } break; case "reloadPage": window.location.reload(); break; } var isJotForm = (e.origin.indexOf("jotform") > -1) ? true : false; if(isJotForm && "contentWindow" in iframe && "postMessage" in iframe.contentWindow) { var urls = {"docurl":encodeURIComponent(document.URL),"referrer":encodeURIComponent(document.referrer)}; iframe.contentWindow.postMessage(JSON.stringify({"type":"urls","value":urls}), "*"); } }; if (window.addEventListener) { window.addEventListener("message", handleIFrameMessage, false); } else if (window.attachEvent) { window.attachEvent("onmessage", handleIFrameMessage); } </script>

    As you can see, I changed the source to https://form.jotform.com/70648516600656. Also, I cleared your form cache so that your forms will be refreshed from our severs.

    Hope that helps. Thank you.