Square integration appears correct but payments are not showing up in Square

  • Profile Image
    cdmakers
    Asked on March 22, 2017 at 07:48 AM

    I've set up a form to integrate with Square.

    All the settings look correct. It is definitely NOT in test mode.

    In my square account, it confirms that an external app (JotForms) is connected.

    But when I put a payment through, JotForms sends me an email telling me that the payment was successful, and even provides a transaction number. But the transaction does not show up in my Square account.

    What might I be doing wrong?

  • Profile Image
    Boris
    Answered on March 22, 2017 at 12:47 PM

    I have checked your affected form with form ID 70802382582860, and I do see that it is integrated with Square.

    Please keep in mind that transaction IDs are created even for submissions made while the Square payment field is set to Test Mode / Sandbox Mode. Square's web interface shows only the transactions made in Live Mode, while Sandbox Mode transactions cannot be seen from their web interface. It looks like you were making your submissions while the Square payment field was integrated in Test Mode.

    Please make sure to edit your form and re-connect it with your live Square account once again, and kindly make a new submission after that.

    Please let us know how it goes.

  • Profile Image
    cdmakers
    Answered on March 22, 2017 at 04:33 PM

    Problem solved. (Problem caused by me being a first-time user).

    What happened was that everything to do with creating the form was being saved automatically, so when I changed the pop-up settings on the side of the page that dealt with Square integration from 'Test' to 'Live', I assumed that the change would save automatically.

    I later discovered that after changing from 'Test' to 'Live' I had to scroll down to the bottom and press the 'Save' button.

    Once I did that, all went well. I did a real transaction with my own credit card and it was perfect. Thanks, Boris, for looking into this for me.

  • Profile Image
    Kevin_G
    Answered on March 22, 2017 at 08:45 PM

    Glad to know you were able to see your integration working as expected. 

    Please, do not hesitate to contact us if you need further assistance.