What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Autoresponders not sending all details

    Asked by bobbielmckee on March 22, 2017 at 12:05 PM

    If I change the email auto-responder it does not send all form field data. I'm trying to add a paragraph to the beginning of the email and if I make any customization's, half of the fields are blank. If I leave the auto-responder unedited, it works fine.

    Thanks,

    Bobbie

    Screenshot
  • Profile Image
    JotForm Support

    Answered by Kevin_G on March 22, 2017 at 04:02 PM

    I've cloned your form and submitted it without making any change to the emails, I can see there're some fields empty in the emails even when they have been filled in your form. 

    I can see you have added multiple email auto-responder emails to your form, what I would suggest you is to check that the field's name is the same like in the properties, otherwise, this may be why you keep receiving those fields empty. 

    This guide will help you to get the field's names so you may compare them with the field's names in your email template: https://www.jotform.com/help/146-How-to-find-field-IDs-and-names 

    You may also try to re-do the email auto-responder, also avoid to make changes to the table containing the submitted data, this may break the hide empty fields feature in the email. 

    If this still persists, please let us know. 

  • Profile Image

    Answered by bobbielmckee on March 22, 2017 at 04:46 PM
    Thank you for getting back to me.
    This issue has happened to a couple forms. All the auto responders you see are from me trying to troubleshoot where it gets broken.
    I have confirmed the form fields are named the same from one that does not work and one that does. I created a new autoresponder and it worked. As soon as I try to edit it, it fails.
    Please take another look.
    Bobbie McKee
    Web Developer
    Barrette Outdoor Living
    7830 Freeway Circle, Middleburg Hts., Ohio, US, 44130
    O: 440-239-5274 C: 216-312-0367
    [Logo Barrette]
    ...
  • Profile Image
    JotForm Support

    Answered by Kevin_G on March 22, 2017 at 06:38 PM

    I've cloned your form and submitted it, I can see what you're reporting in either an email notification or email auto-responder. 

    The issue seems to be related to the fact that you have multiple fields with the same labels and they also have the same fields names. To properly test the issue I created a new form and added to similar fields, set up the same field name to both and I replicated it in my new testing form. 

    What I would suggest you is to check your fields with the same labels, make sure there are not duplicated fields names, otherwise when the info is submitted it will show some empty fields.

    If you want also test the issue, you could clone my form and test what I explained: https://form.jotformpro.com/53008782146960 

    This guide will help you to clone it: How-to-Clone-an-Existing-Form-from-a-URL

    I have two fields named and labeled the same, the same behavior happens with the emails as you're describing, if you change the field name for one of the "Check Box" field then you will notice the issue is not there anymore. 

    Hope this helps.