Translation won't show for a couple questions

  • Profile Image
    lindsayn
    Asked on April 03, 2017 at 01:02 PM

    I'm attempting to translate an English survey to Chinese.  First question is how do I get english to show up as english and chinese to show up as chinese.   If you look at my most recently edited form and go to the preview, chinese is showing when English is the selected language and visa versa.  

     

    Also, there are two fields that I have put a translation in for by it won't show in the preview.  What am I doing wrong?  (Student Academic Performance title and the SAT question)

  • Profile Image
    BJoanna
    Answered on April 03, 2017 at 03:00 PM

    You have set Chinese as current (Original) language of the form and you have set English(US) as translated language.

    Because of that when Chinese is selected English version of the form is shown and other way around. 

    This can only be resolved if you remove translation and add it again.

    Make sure that current language of the form is set to English.

    How to Make your Forms Multilingual

    If after that two mentioned fields are still not translated, let us know. 

    Let us know if you need further assistance. 

  • Profile Image
    lindsayn
    Answered on April 03, 2017 at 04:15 PM

    Ok so how do I remove translations?  There's no button to remove or delete the translations option.

  • Profile Image
    AIDAN
    Answered on April 03, 2017 at 05:20 PM

    You can remove translations by simply clicking on the X button:

    I hope this helps. If you need further assistance please let us know. Thank you.

  • Profile Image
    lindsayn
    Answered on April 04, 2017 at 08:51 AM

    More specific question.  How do I remove both translations?  Specifically Chinese.  I need English to be first.  See above communication for reasoning.

  • Profile Image
    AIDAN
    Answered on April 04, 2017 at 09:21 AM

    It is exactly in light of the above communication that I suggested clicking the X button that I highlighted in my previous reply.

    I have created an animation that demonstrates how clicking on the X button I highlighted, would remove both translations in a clone of your form:

     

    Apologies if that was not clear enough.

  • Profile Image
    lindsayn
    Answered on April 04, 2017 at 10:00 AM

    Thank you for the animation.  I tried that multiple times last week and it wouldn't work!  Works now.  Last question, I still have two questions that won't seem to translate.  Any idea why?

  • Profile Image
    AIDAN
    Answered on April 04, 2017 at 11:45 AM

    You're quite welcome. Could you please point us to the two questions that you are not able to translate so we could inspect them? Thank you in advance.

  • Profile Image
    lindsayn
    Answered on April 04, 2017 at 11:54 AM

    Student Academic Performance title and Has the student started preparing for the SAT/ACT/TOEFL tests?

  • Profile Image
    BJoanna
    Answered on April 04, 2017 at 01:24 PM

    I tested your form and mentioned fields are not translate as you mentioned. I was able to replicate same issue on my cloned form when I re-saved translation. 

    On my cloned form I was able to resolve this issue by deleting question text and re-typing it. Please try the same. Do not paste the field label, type it manually.

    Do the same for other field as well. After that open Form translation and add translation for those fields again.

    Here is my cloned form: https://form.jotformpro.com/70935359379976 

    You can clone it and translate mentioned fields. 

    Hope this will help. Let us know if you need further assistance.