Changes are not reflected immediately on the embedded form

  • Profile Image
    dellquaysc
    Asked on April 06, 2017 at 09:44 AM

    Hi,

     

    Last evening (5th April 2017) I amended one of our forms. Initially it appeared as if the update had not been saved. I checked and checked but on the JotForm pages the update had been saved. However when I attempted to view the page by clicking the link on one of our web pages, the old form kept being served!

    It took some hours before the page on our website, not exactly sure how many hours as I gave up and made diiner. eat it and watched some TV.

    Eventually, the amendments were in fact visible when the javascript link was run from one of our web pages.

    I have not noticed this issue before and have been using JotForm for a few years now. Has something changed? Have you added some sort of caching, did the caching fail during this time? Should I expect to need to wait a few hours for amendments to forms to be visible?

     

    Regards

     

  • Profile Image
    Sven
    Answered on April 06, 2017 at 11:00 AM

    There was no issue regarding that on our end, it could be a browser issue, usually you can log out, clear JotForm cache and cookies, login back again and it should be fine. Did you try from different browsers? 

    Also, can you please specify which form you were experiencing this issue with?

     

    Thank you.

  • Profile Image
    dellquaysc
    Answered on April 06, 2017 at 11:25 AM

    I tried 2 other browser, I refreshed the browser cache (CTRL F5) etc ect.

    The form is run from a javascript link on a Joomla web site using

    <script type="text/javascript" src="https://www.jotformeu.com/jsform/21403189794358">

     

     

  • Profile Image
    Jim_R
    Answered on April 06, 2017 at 01:18 PM

    The only time changes would not immediately take effect on an embedded form is when you're using the Full Source code of the form as your embed method. With this embed method, any changes you do on your form should be accompanied with re-deploying the entire source code to your website again.

    Seeing that you're using the script embed codes, we can rule this out. Although there hasn't been any similar reports, we can have a better look if you we know the page where the form was embedded.

    Just get back to us with the URL to the page on your website where the form resides and we'll have a closer look.

  • Profile Image
    dellquaysc
    Answered on April 14, 2017 at 09:29 AM

    I am having this exact problem again at this very moment.

    I remove 2 fields from the form and when I view the form using the menu "More->View Form" the form shown still has the 2 removed fields shown.

    The form is called "Lift Out - Lift In"

    Maybe if someone is quick off the mark they can have a look at it and see this issue in action.

    I have refereshed the cache in FF which I was using, and tried the url in a seperate browser (Chrome)

     

    Regards.

  • Profile Image
    Chriistian
    Answered on April 14, 2017 at 10:39 AM

    Hi there,

    Based on your Form Revision History, the last fields you have removed where clubName and OutDate and looking at your form, it is no longer there.

     

    Can you please confirm that these are the fields that you removed?

    Regards.

  • Profile Image
    Chriistian
    Answered on April 14, 2017 at 10:41 AM

    Also, as requested by my colleague above, please give us the URL of the page where you embedded the form?

  • Profile Image
    Kiran
    Answered on April 14, 2017 at 10:50 AM

    We are sorry for the inconvenience this may have caused. We have experienced a temporary issue with the syncing process and it has been fixed now by our backend team. Please check again and let us know if you are still experiencing any issue. We will be happy to take a look again. 

    Thank you!

  • Profile Image
    dellquaysc
    Answered on April 14, 2017 at 11:16 AM

    Christian,

    I have not attempted to place a link to this form onto my web site yet, what would be the point?

    This issue is related to ONLY the JotForm development/design tool web pages.

    The fields in question were in fact Visible, and were near the botttom of the page and were a simple HTML field and a Yes/No radio button set. Related to plastic bead blasting.

    The fields you mention, were not removed, they only had there contenst changed.

    I just checked the history of that form, and nowhere are the 2 fields I actually removed actually mentioned, maybe the amendment history feature is also not in the best of health!

    Kiran,

    I have just checked, and the form is now showing correctly.

    Is this now a fixed sort of fixed, or a fixed for now sort of fixed?

    Thanks for the help

  • Profile Image
    bdhmarketing
    Answered on April 14, 2017 at 11:37 AM


    for what it's worth, I was experiencing a similar issue using chrome, but do not have that issue using explorer.

  • Profile Image
    Kiran
    Answered on April 14, 2017 at 12:43 PM

    @bdhmarketing,

    The issue occurred due to a temporary issue with the caches server. However, it has been rectified from our end and the forms should be working fine. You may try logging into a private/incognito window of IE to see if it is an issue with the browser caches. 

    Hope this information helps!