What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Salesforce integration: account not authenticated when attempting to edit integration.

    Asked by ziggil on April 06, 2017 at 01:32 PM

    Hi,

    Recently my SalesForce integration stopped working. To be safe I acquired a new security token, deleted the old integration, signed out of JotForm and Salesforce and then went back in and created the new integration.

    The setup always authenticates initially but nothing gets passed into. When I go back and check the integration it states it is setup. When I click "edit" it shows that it is not authenticated. Very frustrating. Can you help?

     

    Ziggi

    Page URL:
    https://www.unitedspinal.org/join/membership-join/

  • Profile Image
    JotForm Support

    Answered by BDAVID on April 06, 2017 at 03:00 PM

    I could not reproduce the issue. I tried in an old form which was already integrated to Salesforce, and it was still authenticated. I also created a new form, integrated to Salesforce, and then I attempted to edit it, and it was still authenticated:

    What browser are you using? Please try using a different browser. Also try clearing your forms cache: https://www.jotform.com/help/229-How-to-Clear-Your-Form-Cache 

    Let us know if you need more help.

  • Profile Image

    Answered by ziggil on April 06, 2017 at 03:45 PM
    Thanks so much for the quick response. I was using Safari. I’ll clear cache, use a different browser, reintegrate and let you know.
    --
    Ziggi Landsman
    VP of Web Strategy
    United Spinal Association
    ...
  • Profile Image

    Answered by ziggil on April 06, 2017 at 11:44 PM
    Hi, I tried all of the suggestions and still no luck. Again, on initials integration it authenticates but when I check later in “edit” mode it is no longer authenticated (see attachment) and will not authenticate. The form I am working with is United Membership Slide Ins located at: https://form.jotform.com/70145177955159
    [cid:C5BE5D1E-A90D-44AC-A105-959DB23EA0CF@home]--
    Ziggi Landsman
    VP of Web Strategy
    United Spinal Association
    ...
  • Profile Image
    JotForm Support

    Answered by BDAVID on April 07, 2017 at 12:02 AM

    Thanks for letting us know, I have forwarded this to our back-end team to get further help.

  • Profile Image
    JotForm Support

    Answered by NeilVicente on April 28, 2017 at 07:08 PM

    I am the engineer to whom your issue was assigned.

    May I ask if you are still experiencing this problem? If so, can you please tell us the exact error displayed by the integration wizard when you try to authenticate SalesForce with JotForm?

  • Profile Image

    Answered by ziggil on April 28, 2017 at 07:43 PM
    Hi,
    I gave up on this issue but will now reinstall the app in an effort to get it working. In the past there was no error code. The app indicated that it had authenticated but no form information was passed through. If I went back to the app it still stated that it was authenticated. If you pressed “edit” it would then state (in the edit area) that it needed to authenticate but would not.
    I’m going to reinstall the app. Can I contact you after that?
    --
    Ziggi Landsman
    VP of Web Strategy
    United Spinal Association
    ...
  • Profile Image
    JotForm Support

    Answered by NeilVicente on April 28, 2017 at 07:46 PM

    Yes, please. We are committed to having this issue resolved.

    Kindly provide us as much details as possible.

    Thanks!

  • Profile Image

    Answered by ziggil on April 29, 2017 at 03:43 PM
    Hi,
    I made a copy of the form I am trying to integrate so that I could play with it. The form name is “Clone of United Membership Slide Ins”. When I went to integrate with Salesforce the app did authenticate and I was able to select and map fields. I mapped much fewer fields since this is a sandbox form.
    I entered a test submission that archived in JotForm with name “Hot Coffee” but this data did not make it into SalesForce. I went back to the integration app which stated that it was authenticated (see attachment screenshot_1966.jpg). When I clicked on “Edit Integration” I was presented with a popup that stated I needed to authenticate (see screenshot_1967.jpg) but clicking “Authenticate” did nothing.
    In the past I have changed my password and obtained a fresh Security Key but the same thing continues to happen.
    [cid:A56237B1-D239-4639-9463-9A5C3484DE6C@home][cid:F1A3934A-7906-4D8B-879D-AD6B1610D51F@home]
    --
    Ziggi Landsman
    VP of Web Strategy
    United Spinal Association
    ...
  • Profile Image
    JotForm Support

    Answered by Kevin_G on April 29, 2017 at 09:00 PM

    Thank you for  the additional details Ziggi. 

    I have also tested this on my end and I was unable to replicate the issue. 

    Also, your screenshots did not reach this thread, could you please re-upload them by following this guide: How-to-add-screenshots-images-to-questions-in-support-forum

    This comment has reached our developer as well so he will also receive the images with the problem you're facing. 

     

  • Profile Image

    Answered by ziggil on April 30, 2017 at 12:14 AM

    Sorry about the images. I have attached and will repeat the issue. The image Authentication.jpg is what I see when checking back after installation, after entering a test submission, and after confirming that data was not captured by Salesforce.

    The second image (Integration.jpg) is what I see when I click on "Edit Integration" at the above view. When integration was set up the Authentication was verified but after one failed submission and checking back I get what you see on the attached "Integration.jpg". I can click Authenticate but it changes nothing on the screen.

     

     

  • Profile Image
    JotForm Support

    Answered by jonathan on April 30, 2017 at 03:52 AM

    Thank you for providing us with the requested details and screenshot image of the actual issue.

    Our developer assigned on the bug ticket report will update us with a response on this thread when available.

    Regards

  • Profile Image
    JotForm Support

    Answered by NeilVicente on April 30, 2017 at 05:09 AM

    You were able to integrate at first using the same credentials, correct? And after integrating, you tried to edit the integration and the error came up.

    The error that came up says exactly what is wrong.

    Did you, by any chance, change your SalesForce account password after integrating the form? I am asking this because SalesForce also changes your security token whenever you change your password.

    Please kindly check your email to see if SalesForce sent you a new security token.

  • Profile Image

    Answered by ziggil on April 30, 2017 at 09:53 AM

    No, I was able to authenticate but integration never happened. After seeing that no data was being captured by Salesforce, I went back to check the integration and that is what I saw.

    I have used a fresh security key (several times) with the same results. My credentials are good since I have no problem accessing Salesforce with them.

    I'm going to create a new test form with only 2 fields, name & email and test that. The existing form is very long with a great deal going on. There may be issues with the fields so a fresh start may be the way to go for now.

  • Profile Image
    JotForm Support

    Answered by NeilVicente on April 30, 2017 at 04:38 PM

    When were you able to authenticate? Can you please leave the form as is after authenticating and let us know so we can check for problems in the backend?

    Thanks!