What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    New theme not applying to existing form

    Asked by colinSM on April 10, 2017 at 11:46 AM

    I'm trying to apply a new theme to an existing form.

    Within the builder it appears the theme applies with no problem, but when I go to embed the form or preview the form it reverts back to the original theme.

    I don't want to have to re-create every form I have and only want to apply it to existing forms.

     

    Is this a caching issue on Jot Form's side? As I've cleared the cache on my own browser to make sure this isn't the case.

     

    Thanks

  • Profile Image
    JotForm Support

    Answered by david on April 10, 2017 at 12:49 PM

    I checked applying themes to form on my end and it looks to be working.  Before applying a new theme, make sure to remove the old on first.  Remove the old theme, refresh the page to ensure it is removed, then go back and apply the new one.

    If this still does not work, let us know which form you are working with and what theme you are trying to apply.  We will be happy to have a look.

  • Profile Image

    Answered by colinSM on April 11, 2017 at 04:26 AM

    Thanks for this David

    I've tried as you said to remove the theme, then refresh the page, apply the new theme. It looks ok in the builder but then previewing still doesn't work. Then when I refresh the page the theme goes back to the state it was originally in.

     

    This is for my client: AFC_Digital and the form is "Mini Byte".

     

    The theme I'm trying to apply is "AFC Form Theme".

     

    I've also just realised that when I go to edit the theme, all my CSS and customisation is gone! D:

    But the theme when selected in the builder looks correct when removed and applied.

  • Profile Image
    JotForm Support

    Answered by Chriistian on April 11, 2017 at 04:44 AM

    I checked the form Mini Byte (http://www.jotformeu.com/form/70723871379364) and here's what it appears on my end on the Preview Mode.

     

    When I checked it from the Form Builder, I noticed that AFC Form Theme isn't selected as the the theme.

     

    If the issue still occurs, please try clearing your form's cache. Here's a guide on How to Clear Your Form Cache? and please try applying the theme again.

    Do let us know if you need further assistance.
    Regards.

     

  • Profile Image

    Answered by colinSM on April 11, 2017 at 04:51 AM

    I've tried as you have advised. I've even cleared my form cache. But here's the issue that I'm having.

    When I apply the theme and come back to the form this is how it's displayed:

    The look of this form is then incorrect. It's not what was originally within the theme.

     

    I then go to remove the theme and re-apply the theme.
    Then my form looks like this:

    This is the correct way the form should appear. This is the right theme.

     

    However then when I go into preview mode the form appears as so:

     

     

    I then gone to edit the theme and ALL of the CSS has disappeared and isn't there anymore.
    I've tried clearing my browsers cache, my form cache. But still this persists.

  • Profile Image
    JotForm Support

    Answered by Chriistian on April 11, 2017 at 05:32 AM

    I checked the form and I was able to replicate the issue. I will raise this issue to our dev team for further checking. We will let you know in this thread if there are any updates.

    Regards.

     

  • Profile Image
    JotForm Developer

    Answered by berkay on April 12, 2017 at 07:30 AM

    Hi,

    We are sorry for interruption, It looks you had an error which caused by our theme revision system.

    I have fixed it. You can keep using your theme.

    Please let me know if you need any further information.

    Regards,

    Berkay. 

  • Profile Image

    Answered by colinSM on April 12, 2017 at 11:00 AM

    Hey Berkey

     

    It still seems like the issue is still persisting.
    However I've saved out the original CSS I was using.

     

    SO. Is there any chance of removing the three themes called "Remove" and "AFC Form Theme" on the account: AFC_Digital. These were created when things were swapping over on here at the time. So think something messed while doing so.

     

    Once these are deleted I'll create a new theme and apply it to the current forms and see if the issue is resolved.

  • Profile Image
    JotForm Support

    Answered by david on April 12, 2017 at 01:13 PM

    I deleted the three themes you mentioned.  They should now be removed from the theme store for AFC_Digital.

  • Profile Image

    Answered by colinSM on April 13, 2017 at 09:27 AM

    Ok I've tried to create a new theme.

    However in the designer I can't see any way of previewing this in another form.
    AND the name of the theme is never displayed within the editor.
    In the editor I've attached the name of the theme I see in the upper left hand corner.

     

    The form builder is version 4 for my client. Would this have something to do with it?

  • Profile Image

    Answered by KadeJM on April 13, 2017 at 11:15 AM

    We appreciate the update about trying this again.

    It looks like you've gone through the process of making a theme but, are not able to find the theme and it's name in editor when trying to apply it if I am not mistaken.

    Even though you are using the latest formbuilder v4 that shouldn't affect it as far as I know.

    Please allow us some time to check on this further to figure out what's happening with it.

     

  • Profile Image

    Answered by KadeJM on April 13, 2017 at 02:03 PM

    After checking on this problem with your themes again further I found that the form you are now designing is this one - http://www.jotformeu.com/form/63273850083355 but, other than your red font and the submit animation it seems to be applied to http://www.jotformeu.com/form/70723871379364

    Is that the same form you are still trying to apply it to then? Or are you using a different one?

     

    It looks like your form as a different theme applied to it using this one https://support.jotform.com/theme-store/theme/afc-website-form and I'm not seeing any errors at the moment but I do see the other theme listed for the AFC Theme.

    Is it still defaulting on your end?