Can't save changes through Advanced Designer

  • Profile Image
    katyarun
    Asked on April 18, 2017 at 04:08 PM

    Hello! I'm having trouble with my Advanced Designer, can't save anything through it (any of my forms). Just like in these treads:

    https://www.jotform.com/answers/1114957

    https://www.jotform.com/answers/1073688-I-cannot-save-any-changes-made-through-the-advanced-form-designer

    https://www.jotform.com/answers/1114841-Advanced-Form-Designer-Changes-made-to-the-form-not-saving

    I'm working on MacOS Sierra 10.12.4 with Safari and Chrome (and also tried for this bug Firefox). I was cleared cache at Jotform settings and on my Chrome & Safari browsers. And restart macbook. Nothing helped unfortunately. It started at sunday, almost two days ago. Can you help me? 

  • Profile Image
    david
    Answered on April 18, 2017 at 07:07 PM

    I tested this with one of my own forms and I am able to reproduce the issue.  It seems any changes made are not currently saving.  CSS added does save, but the process in the advanced designer does not look to complete.

    I changed the highlight color and then attempted to save the changes, but errors were produced and the changes would not save:

    I will forward this to our developers to have a look.  We will let you know as soon as it is fixed.

  • Profile Image
    TreasureKwest
    Answered on April 18, 2017 at 08:12 PM

    I am having the same issue and will follow the resolution.

     

    Thank you,

    ~J

  • Profile Image
    EltonCris
    Answered on April 19, 2017 at 02:08 AM

    @TreasureKwest

    We will let you know in your thread here https://www.jotform.com/answers/1122729 once this is resolved.

  • Profile Image
    EltonCris
    Answered on April 19, 2017 at 02:51 AM

    The problem was related to our server. This is fixed now.

  • Profile Image
    katyarun
    Answered on April 19, 2017 at 03:41 AM

    @EltonCris

    But it doesn't work to me, I still have the same issue

  • Profile Image
    Charlie
    Answered on April 19, 2017 at 03:56 AM

    Apologies for the inconvenience. We just received news from our developers that they are doing an upgrade. We will let you know once this is fixed again. 

  • Profile Image
    Charlie
    Answered on April 19, 2017 at 05:24 AM

    Hi,

    We received news from our developers that this should now be fixed. Could you please try again?

    If you are still having problems, please try the following:

    1. Log out and log back into your account.

    2. If step 1 does not work, try clearing your browser's cache

     

    Let us know if you are still having problems.

    Apologies for the inconvenience. 

  • Profile Image
    katyarun
    Answered on April 19, 2017 at 04:11 PM

    Great! It works now, thanks a lot!

  • Profile Image
    katyarun
    Answered on April 19, 2017 at 07:25 PM

    Oh, sorry, I checked Advanced Designer only on css. Design still not saving :(

  • Profile Image
    katyarun
    Answered on April 19, 2017 at 08:10 PM

    And, also, I don't know, is it bind with issue, or not, but Advanced Designer in Safari's private window looks strange (but in Chrome's it's normal)

     

  • Profile Image
    stuarthickman
    Answered on April 20, 2017 at 01:10 AM

    Yes mine not saving Advanced Designer changes either - have tried relogging in and clearing cache.  Any eta on a fix?  Cheers
  • Profile Image
    Charlie
    Answered on April 20, 2017 at 02:54 AM

    I cloned your form and tested the Advanced Designer on my end, I'm able to make changes using that and it shows in my live form. Here's my live form: https://form.jotform.com/71091564665966 

    Here's a screencast showing how I am editing it: 

     

    For the issue regarding the Safari browser, I opened a separate thread for it, you can refer to this link instead: https://www.jotform.com/answers/1124106. We will address that one accordingly. Thank you.

  • Profile Image
    Charlie
    Answered on April 20, 2017 at 02:55 AM

    @stuarthickman

    To better assist you, I opened a separate thread for your concern, please refer to this link instead: https://www.jotform.com/answers/1124104. We will address it accordingly. 

    Thank you.

  • Profile Image
    katyarun
    Answered on April 20, 2017 at 03:47 AM

    Hi! Sorry, but it still the same 

     

    Response Headers

    cache-control:post-check=0, pre-check=0

    cache-control:no-store, no-cache, must-revalidate, max-age=0

    cf-ray:3526705238bb0663-SJC

    content-type:text/html; charset=UTF-8

    date:Thu, 20 Apr 2017 07:37:31 GMT

    expires:Tue, 03 Jul 1970 06:00:00 GMT

    last-modified:Thu, 20 Apr 2017 07:37:31 GMT

    p3p:CP="NOI ADM DEV PSAi COM NAV OUR OTRo STP IND DEM"

    pragma:no-cache

    server:cloudflare-nginx

     

    Request Headers

    :authority:www.jotform.com

    :method:POST

    :path:/API/form/71091673671156/style

    :scheme:https

    accept:application/json, text/javascript, */*; q=0.01

    accept-encoding:gzip, deflate, br

    accept-language:en-US,en;q=0.8,ru;q=0.6,fi;q=0.4

    content-length:16510

    content-type:application/x-www-form-urlencoded; charset=UTF-8

    origin:https://www.jotform.com

    referer:https://www.jotform.com/themes/

    user-agent:Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.133 Safari/537.36

    x-requested-with:XMLHttpRequest

  • Profile Image
    Charlie
    Answered on April 20, 2017 at 03:58 AM

    I'm sorry to hear that. Could you tell us what specific changes are you doing in the Advanced Form Designer Tool? Are you changing the color, font, basic them, etc...? Also, can we ask permission that we log in to your account and make changes on that specific form using the Advanced Form Designer Tool? That would allow us to test it further. 

    We'll wait for your response. 

  • Profile Image
    katyarun
    Answered on April 20, 2017 at 04:26 AM

    Usually I tried change color scheme, cause it faster to check about this issue, but it doesnot work with anything (right now I checked from width, for example)

    Here is changing color scheme: 

    Yes, sure you can have permission.

    Also, I tried create new forms from templates periodically, but they all have this bug

  • Profile Image
    Nik_C
    Answered on April 20, 2017 at 04:41 AM

    I was able to replicate this problem you described. And I notified our backend team already.

    Thank you for reporting it. 

    We will inform you once we have more information.

    Thank you for your patience.

  • Profile Image
    KadeJM
    Answered on April 20, 2017 at 10:59 AM

    I just wanted to update you and let you know that we've been informed that this is now fixed.

    I've tested this again on my end where I am no longer seeing the issue and it is saving without any errors found on my side of things as another test to check on your behalf.

    Can you please check it again on your end to confirm or let us know when you have a moment?

  • Profile Image
    katyarun
    Answered on April 20, 2017 at 06:09 PM

    Hi!

    Now it works perfect! Thank you guys for helping me :)

  • Profile Image
    gmoim
    Answered on April 22, 2017 at 04:03 PM

    I'm having the same problem now. Can't save anything in Advanced Designer...  

    Tried everything. Using Opera, but have tried Safari, Chrome and Firefox as well. Please advise. 

  • Profile Image
    Nik_C
    Answered on April 22, 2017 at 05:11 PM

    @gmoim,

    I opened a separate thread for you and we will attend it here: https://www.jotform.com/answers/1126227

    Thank you!