How do fix this issue with sub-label?

  • Profile Image
    Davidgilbertvo
    Asked on April 21, 2017 at 12:58 PM

    3) how do fix this issue - top view is of a filed with sub-label that doesn't show up in "Preview Form", while the second image shows the same form in "Build" view which is exactly how i want it to appear. And to this point, there doesn't seem to be an option to alter the format of the sub-label text.

    Thanks!

  • Profile Image
    BJoanna
    Answered on April 21, 2017 at 01:23 PM

    I have inspected your form and I was not able to replicate mentioned issue. Sub-label text is not outside of form frame. I have inspected your live form and your form inside of Form Builder and Form Designer. 

    Were you able to resolve your issue? 

    If the issue still persist on your end, please let us know which device and browser are you using. 

    If the form is embedded, please provide us URL of the webpage. 

    Let us know if you need further assistance. 

  • Profile Image
    Davidgilbertvo
    Answered on April 21, 2017 at 01:39 PM

    Hi. I added the following CSS coding that seems to have helped the issue:

    label.form-sub-label {

        white-space : normal !important;

    }

    However, I still have an issue where I HAD tried to align all the fields so that the labels are on the left and the fields on the right. Can you please take a look again and see how I can fix this? Thx.

    I also found an issue where the Date condition I set doesn't seem to do anything - trying to make sure that if a user enters a date in one field that is earlier than the date in another it forces them to go back and reenter a new date in the first field.

    https://form.jotform.ca/71087847965271

  • Profile Image
    BJoanna
    Answered on April 21, 2017 at 03:00 PM

    There is not enough space inside of your form to align all labels to the left of the fields, because you have input set width of your fields to 500px.

    You can increase the width of your form to 700 px, to resolve this issue.

     

    Here is my demo form: https://form.jotformpro.com/71106007451948 

    Feel free to clone it.

    I have moved your issue with conditional logic to separate thread and we will provide you an answer there shortly. 

    https://www.jotform.com/answers/1125724 

  • Profile Image
    Jim_R
    Answered on April 22, 2017 at 12:45 PM

    @Davidgilbertvo - Did you reply to your thread? If so, we never saw your post. If you need more help about this same topic, open your thread by clicking this link, then post your reply from there.

    Or if your question is about a different topic, kindly open a new thread instead by going to this page.

  • Profile Image
    David A Gilbert
    Answered on April 22, 2017 at 01:45 PM

    Yes, all good for now. Thanks!