What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form tells me there are incomplete values when there are not.

    Asked by TortolaExpress on April 22, 2017 at 03:27 PM

    WE have an issue with this form:  http://form.jotformpro.com/form/60594272062959

     

    After filling out all the details and having every required field (see proof) filled, we get the incomplete values message.  Below are some screens of the form having been filled and then the error message.  

     

    Also it seems that sometimes this error occurs and sometimes it does not.  Lastly, when the "incomplete values" message used to pop up, the user was able to Click "go back", then resubmit.  Upon "going back" the user just had to re-enter their Staff name and then it would go through.  Now when we "go back" the form is blank.

    Any ideas?

     

     

     

     

     

  • Profile Image
    JotForm Support

    Answered by jonathan on April 22, 2017 at 05:48 PM

    I test submitted your form  https://www.jotform.com/form/60594272062959 but I did not encounter the same error.

    on my submission, it successfully show the Thank You message page after.

    Can you please check again. Perhaps it was a temporary glitch only.

    Let us know if issue persist.

     

     

     

     

     

  • Profile Image

    Answered by TortolaExpress on April 24, 2017 at 10:05 AM

    It is sporadic.  The issue is not always replicable.  maybe try a few submissions...

     

  • Profile Image
    JotForm Support

    Answered by david on April 24, 2017 at 11:49 AM

    I also tried submitting the form and my submission went through without issue.  Is the form embedded to a web page by any chance?  I cloned the form and sent several tests through the clone, each one went through.   I tried with and without files being uploaded, everything looks OK.

  • Profile Image

    Answered by TortolaExpress on April 24, 2017 at 12:32 PM

    The only other thing i can think of is that the form is partially filled from a previous form.  

     

    Go to https://sites.google.com/a/aeropost.com/report-centre/

    Then select Aeroprotect Return.  Then use name Colin and the rest should fill out.  Then the  form in questions will get pre-filled with the name and email address.  

     

    So the initial URL is a little different but I don't see why taht should make any difference.  "I use this "form Selection" so I can get users to put in their info and I don;t have to update all the dropdown menus  in every form.

     

  • Profile Image
    JotForm Support

    Answered by david on April 24, 2017 at 01:44 PM

    The only possibility I can think of is that the selection is not actually being seen in the form when it is selected via the URL.   The form itself is working when the options are selected manually.  Though when I tested through the link in your page then through the redirect, I was still unable to reproduce the issue.

    If you happen to find a way to consistently reproduce this, let us know and we will look into this further.  I am hesitant to test further since I have already sent a few submissions through your forms. 

  • Profile Image

    Answered by TortolaExpress on April 24, 2017 at 03:05 PM

    I will be able to tell which submissions are test and which are not, so no issue to continue testing.  Problem is that we continue to experience the issues so that is a real bummer.

  • Profile Image

    Answered by TortolaExpress on April 24, 2017 at 04:01 PM

    I just remembered that before all of these issues I had changed the properties of one of the fields. The Return Documents field was changed from single to "allow multiple" to allow multiple documents to be uploaded.  So I changed that back to just the single and the users experiencing the problem, no longer have the problem...

  • Profile Image
    JotForm Support

    Answered by david on April 24, 2017 at 05:05 PM
    Does the issue persist if you use multiple single file upload fields?