Hidden fields showing on my form...

  • Profile Image
    plott
    Asked on April 23, 2017 at 05:53 PM

    I have a number of hidden fields on my form.  When the form launches, some of them are showing.  I can't figure out why this is the case.

  • Profile Image
    jonathan
    Answered on April 23, 2017 at 07:09 PM

    On your form https://form.jotform.us/71113200720132 can you please tell us which condition rules were failing? It could be due to faulty condition rules on the form.

    On initial loading of the form, can you tell us which field/s were suppose to be hidden but instead were showing already when form loads?

    We will look into this further once we get a better understanding of the issue.

    Thanks.

     

  • Profile Image
    plott
    Answered on April 23, 2017 at 07:23 PM

    For example, Middle School Weight Class is showing - it is a hidden field.  So, at this point the conditions aren't failing, but the fields are hidden and I wouldn't expect them to show until a condition "shows" them.

     

  • Profile Image
    jonathan
    Answered on April 23, 2017 at 08:25 PM

    Thank you for providing us with the requested details. I see the problem when I view your form.

     

    The issue happens due to faulty condition rules you have on the form.

     

    To fix, remove all the Hide conditions that affect the field since it was actually already in Hidden mode.

    You can Show it using this condition only 

     

    it should work like this...

     

    Here is my test form https://form.jotformpro.com/71127820244954

    Let us know if you are still not able to fix it.