How can I embed a PowerPoint presentation into a form?

  • Profile Image
    POME3790
    Asked on May 01, 2017 at 05:42 PM

    I have searched through the forum and note that the last response to this was in 2013, has the situation changed since then, Can I now have a PPT file on my form?

  • Profile Image
    EltonCris
    Answered on May 01, 2017 at 06:55 PM

    That's possible if you are going to use the online Powerpoint app by Microsoft https://office.live.com/start/PowerPoint.aspx. Once you're done, you can simply get your iframe embed code.

    Then paste the embed code in your form using the Text element. Here's how:

  • Profile Image
    POME3790
    Answered on May 01, 2017 at 06:58 PM

    Thanks for responding so quickly Elton.

     

    Cheers, great help!

  • Profile Image
    POME3790
    Answered on May 04, 2017 at 05:42 AM

    Thanks again for your advice, however, I have hit a challenge. When I did this the first time it went OK, however, the second time I edited the unit, enlarged the PP't and re-loaded the code is showing beneath the PP't on the form.

     

    Here is the form:

    https://form.jotform.co/71204839984870

    The access code is 1066, can you help please?

     

    Thanks again

  • Profile Image
    Nik_C
    Answered on May 04, 2017 at 06:20 AM

    The issue is in the code you used, you can notice that between the iFrame tags (code in green) there is some text, that you don't need actually:

    <p><iframe src="https://onedrive.live.com/embed?cid=2C688F83C9F2AD64&amp;resid=2C688F83C9F2AD64%21495&amp;authkey=ALPwqPLe6_q1gpE&amp;em=2&amp;wdAr=1.7777777777777777" width="610px" height="367px" frameborder="0">This is an embedded &amp;amp;amp;amp;amp;lt;a target="_blank" href="https://office.com" rel="nofollow noopener" rel="noopener noreferrer" data-mce-target="_blank" href="https://office.com" rel="nofollow noopener"&amp;amp;amp;amp;amp;gt;Microsoft Office&amp;amp;amp;amp;amp;lt;/a&amp;amp;amp;amp;amp;gt; presentation, powered by &amp;amp;amp;amp;amp;lt;a target="_blank" href="https://office.com/webapps" rel="nofollow noopener" rel="noopener noreferrer" data-mce-target="_blank" href="https://office.com/webapps" rel="nofollow noopener"&amp;amp;amp;amp;amp;gt;Office Online&amp;amp;amp;amp;amp;lt;/a&amp;amp;amp;amp;amp;gt;.</iframe></p>

    You can simply delete that and everything will work fine. Since that is the text that shows up in the form on preview, which is actually normal, but you don't need that for what you're trying to do.

    Let us know how it worked and if you need further assistance.

    Thank you!

  • Profile Image
    POME3790
    Answered on May 04, 2017 at 08:37 AM

    Thanks. I did as you suggested, I copied the text in green from above and nothing worked!!! I must be doing something wrong here, as I said it worked perfectly the first time I did it!!!!!!!

  • Profile Image
    seth
    Answered on May 04, 2017 at 09:53 AM

    Hello,

    I see that your form is working properly:

    Could you please try again? Please also try this URL:

    https://form.jotform.com/71204839984870

     

    If your issue continues, please contact us again.

    Thank you.

  • Profile Image
    POME3790
    Answered on May 04, 2017 at 03:01 PM

    Thanks again, I tried again, this time I excluded the green part of the code, only using the yellow shaded text and it has worked.

     

    Thanks again

  • Profile Image
    EltonCris
    Answered on May 04, 2017 at 03:39 PM

    Great! We are glad to know that it is working now.

    If you have any other questions, let us know by opening a new thread.