Form calculations are being cleared upon clicking the submit button.

  • Profile Image
    twhite1969
    Asked on May 17, 2017 at 02:25 PM

    Hi this form is used to as a weekly timesheet.  The final tab has a summary of the weekly time.  The summary data  appears to work fine before submission but when clicking edit submission on a submitted form you can see that the summary data is not populated anymore.

     

    This form used to work great but there was a JotForm issue on March 23rd related to calculations that impacted all of my forms.  When the issue was resolved my forms worked fine again except this one.  I have been trying to get this form to work since then to no avail.  

    I tried reverted the form back to pre March 23rd but the issue remains.  

    I cloned the form but that didn't work.  I tried multiple browsers machines, devises and clearing cache.  

    Clicking edit submission on entries before March 23rd work fine still.  It is only happening with entries after March 23rd.  

    Here is a link to a cloned version if you want to enter test cases.  The issue occurs in the cloned version as well.  https://form.jotform.com/71365639048968

     

    Any help would be greatly appreciated!

     

    Terence

  • Profile Image
    Kevin_G
    Answered on May 17, 2017 at 03:56 PM

    I have checked your form and I can replicate what you're mentioning, the issue seems related to the calculations on your form. 

    I can see you're using some conditions to get calculated results, but there are some conditions with missing fields, do note that this may be affecting the other conditions on your form: 

    Also, upon checking some calculation widgets on your form, I can see there are missing fields as well, this may be causing the issue with the calculations on your form, since there are some fields set up correctly it performs the calculations while filling the form. 

    This is why the issue can be replicated even on cloned forms. I would also suggest you to set the form to do not clear hidden fields. 

    Please, make these changes to your form and let us know how it goes. 

  • Profile Image
    twhite1969
    Answered on June 01, 2017 at 10:57 AM

    Hi Kevin,

    Thanks for the response.  Sorry I didn't respond sooner.  

    I see the "missing field" in the calculations.  I'm not sure how that happened.  It appears to be on most of the calculations.  

     

    I changed the clear hidden field option.  Also I cloned the form and updated some of the missing field calculations and received the same error.  My guess is that if I take days to update all of them I will still experience the same error.  

    All of the entries entered before the issue started on March 23rd are still working.  I can send you examples if you like.  Why could that be?  Is it possible to revert the form back before that date?

    Why does the calculations with the missing fields work upon entry but disappear when after saving the entry.

    This form was working great for a long time and I have been trying since the March 23rd issue to get it working again.  Currently I have to enter the time again to get the calculation to re-run and I am printing to pdf.  It takes a lot of extra time each week.

    I am willing to make the changes to all of the missing field calculations but I'd like to know that making those changes would work.  Based on cloning the form it appears the error will keep occurring.  

    Thanks for your help.

    Terence

  • Profile Image
    twhite1969
    Answered on June 01, 2017 at 11:52 AM

    URGENT

    Something has happened today with this form and all the cloned versions I have made over the past few months.  

    All the data is lost when I click edit submission and I am unable to retrieve it.  When I view submissions I can see that data is there even though it is incorrect based on the issue above.  But when i click edit submission all of the fields are blank.  This just started happening an hour or so ago.

    This is urgent because I need this data to pay employees today.

    Now all I am looking to do is get the form back to where it was yesterday so I can pay the employees and deal with the other issues later.  

    Your help is greatly appreciated.

    Thanks,

    Terence

  • Profile Image
    Kevin_G
    Answered on June 01, 2017 at 01:19 PM

    Apologies for the inconveniences this may have caused to you, please allow me some time to check your cloned form and make a clone on my end, I will further investigate the issue since it seems to happen only with  your form. 

      Is it possible to revert the form back before that date?

    Yes, it is possible to revert your form back to a previous version, please check this guide that will help you doing so: https://www.jotform.com/help/294-How-to-View-Form-Revision-History 

    Regarding to your second issue, I have moved it to a different thread, we will assist you as soon as possible on this link: https://www.jotform.com/answers/1160550