Why do the links to my forms say ...jotform.us... and not ...jotform.com... ?

  • Profile Image
    sararegina
    Asked on May 17, 2017 at 06:43 PM

    My organization has been using JotForm without issue for the better part of a year, but I have just today run into a perplexing issue. The links to our forms are all formatted like this https://form.jotform.us/70436084098157 with a ".us" in the middle rather than ".com". In this format, the links all give an error saying "Your connection is not secure." If I manually change the URL to ".com", the links work. 

    I'm concerned that this may interfere with forms we have sent out for grant applications with a deadline that is quickly approaching.

    I'd appreciate any help/insight you can provide. Thank you!

    Screenshot
  • Profile Image
    EltonCris
    Answered on May 17, 2017 at 08:23 PM

    Hello,

    Depending on the country you are in or on your profile location, there will be an assigned domain to your forms. This was implemented a few years ago to limit the impact of any possible domain suspensions in the future.

    However, we have lifted the strict limit on domain separation rule so feel free to use jotform.com domain whenever you like. But default domains assigned to your forms will be the same when you take them in the form builder.

    Anyway, I checked your form here with the joform.us domain and I could not reproduce the problem. I see no problem with the security certificates. The page is secure and the security indicator is visible in the address bar.

    Perhaps the issue might have something to do with your browser? Have you tried checking it using a different browser? There should be no issue with jotform.us

    We'll await your reply

     

  • Profile Image
    sararegina
    Answered on May 19, 2017 at 10:27 AM

    Thanks for your response! I did try multiple browsers and had the same issue. However, I now believe it must have something to do with my workplace computer or internet security because just as you said, the jotform.us domain works fine from my home computer.

  • Profile Image
    david
    Answered on May 19, 2017 at 12:22 PM

    It could be that your network has jotform.com flagged as an acceptable site but not jotform.us.  Both domains use the same security certificates and settings so there should be no difference.  I do not see any security warnings from jotform.us on my end on any of the devices I tried.