Can we use the previous version?