Why is the form jumping to top with wix integration?

  • Profile Image
    darkangel579
    Asked on May 30, 2017 at 10:34 AM

    hello my form keeps jumping to the top and is not user friendly when in viewed on a smartphone.

     

    I did mobile responsiveness form.  I tried previously adding the no jump but it didnt work so i removed it and put the form how it was before.

  • Profile Image
    Nik_C
    Answered on May 30, 2017 at 12:18 PM

    I tested your form in iPhone 6s and iPhone 7+, but I wasn't able to replicate this issue. The form loaded fine.

    Could you please give us more information how the form jumps, is it on load or at some other point?

     

  • Profile Image
    darkangel579
    Answered on May 30, 2017 at 12:24 PM

    It it loads fine. But when you got I actually fill it out it jumps and can't scroll down. 

  • Profile Image
    Nik_C
    Answered on May 30, 2017 at 02:00 PM

    Thank you for additional information.

    Is this issue happening on some specific device? Since I tested again on iPhone and on Android phone but I couldn't replicate this issue.

    Thank you!

  • Profile Image
    darkangel579
    Answered on May 30, 2017 at 02:28 PM
    it jumps around 
    but when you scroll back up its usually fine
    but it's a little odd
     
    Did you try to fill out the form going all the way down?
  • Profile Image
    Nik_C
    Answered on May 30, 2017 at 02:52 PM

    I filled the whole form all the way down but didn't notice anything unusual.

    On which device did you test your form?

  • Profile Image
    darkangel579
    Answered on June 02, 2017 at 02:18 PM

    iPhone7plus. I have others using gm the form and same problem. It jumps when filling it on the phone. Anything after the addrsss. And when hitting submit it goes to top and you can't make a payment. Please fix. 

  • Profile Image
    BJoanna
    Answered on June 02, 2017 at 03:52 PM

    I do not have iPhone7 plus, so I have tested your form on iPhone7 plus emulator and I was able to replicate mentioned issue. 

    I have inspected your webpage and I saw that you have embedded your form with iFrame code, without script part. I saw that my colleage suggest you that, on this thread https://www.jotform.com/answers/1158016

    Please add ?nojump at the url of the iFrame code, to see if that will resolve your issue.

    <iframe id="JotFormIFrame-71493911315960" onload="window.parent.scrollTo(0,0)" allowtransparency="true" src="https://form.jotformpro.com/71493911315960?nojump" frameborder="0" style="width:100%; height:2133px; border:none;" scrolling="no"> </iframe>

    Also please note that there is no need to report same issue on multiple threads.

    Let us know if you need further assistance. 

  • Profile Image
    darkangel579
    Answered on June 02, 2017 at 04:00 PM

    I did that before in the code and it did not work so I changed it back. 

  • Profile Image
    BDAVID
    Answered on June 02, 2017 at 06:17 PM

    If you are embedding it through the website address Wix option: https://www.jotform.com/help/70-Adding-a-Form-to-Your-Wix-Site 

    Try adding "?nojump" a the end of your jotform URL. Let us know if that helps.