What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    I get a "file not found" message when I try to edit my forms

    Asked by Rick Bowser on June 02, 2017 at 07:48 PM

    I get a "file not found" message when I try to edit my forms in Jotform although I'm able to view each form through the "more" drop down menu. I can't even submit the question when logged into my account, I get a Jotform Error for Site owner: Invalid domain for site key that won't allow me to push the Submit key.

    Screenshot
  • Profile Image
    JotForm Support

    Answered by BJoanna on June 03, 2017 at 03:15 AM

    If I understood you correctly, you are not able to open your form inside of Form Builder and edit them.

    Email address you used to post this thread is email address of account with username rickeb. I have logged into that account, but I was not able to replicate mentioned issue. I was able to edit the forms.

    I have cleared your form cache and I have whitelisted your IP address. Please try to edit your form again. You can also try to use some other browser or device. 

    Let us know if you need further assistance. 

  • Profile Image

    Answered by rickeb on June 03, 2017 at 06:23 AM

    You do understand correctly. I had the same problem with all browsers. What ever you did solved the problem. Do you think it was merely a cache issue? What does whitelisting my IP mean and why would it need to be whitelisted?

    Thank you in advance.

  • Profile Image
    JotForm Developer

    Answered by Helen on June 03, 2017 at 06:40 AM

    Hello Nick,

    We are glad for your issue was solved.

    Whitelisting means marking the domains or IP's as acceptable. Maybe, your IP address was banned from our system then, you were not able to not edit your form.

    Or maybe you had a temporary issue about editing your forms and after it solved, you had still problem cause of caches.

    If you have any other questions or issue, please do not hesitate to contact us.