Why aren't my secure forms showing https://?

  • Profile Image
    dannybeen
    Asked on July 25, 2012 at 07:03 PM

    I have been adding secure forms to my clients website.  They show up as secure in the back office of his WordPress website.  However, when I look at the links in "live" view, the https:// doesn't show up.

    Here's an example - http://arkrealestateschool.net/pre-license-re-broker-course-registration-form-full-tuition/ This is set up as a secure form in the back office.

    I have them set up in an iframe.  Does this  make a difference?

    Please email your response to secondself@citlink.net.

    Thank you.

  • Profile Image
    Mike_T
    Answered on July 25, 2012 at 07:45 PM

    Thank you for contacting us.

    As far as I can see, everything is right with your embed secure form. Please check the following screenshot to make sure that form is using secure SSL connection.

    If you need any further assistance on this, please let us know. We would be happy to help.

  • Profile Image
    dannybeen
    Answered on July 25, 2012 at 07:51 PM

    The https is on the form URL.  Why doesn't it show up in the address bar when I click on the appropriate link? 

    This is how it shows in the address bar:

    http://arkrealestateschool.net/pre-license-re-broker-course-registration-form-full-tuition/

    I'm at a loss.

    Thank you.  Anymore suggestions?

  • Profile Image
    Mike_T
    Answered on July 25, 2012 at 08:07 PM

    You can use either http or httpS link to access the site. Since you have embed your form using secure method, both options will load secure form.

    http://arkrealestateschool.net/pre-license-re-broker-course-registration-form-full-tuition/

    https://arkrealestateschool.net/pre-license-re-broker-course-registration-form-full-tuition/

    Please note that httpS://arkrealestateschool.net link is related to SSL certificate installed on your website. You have some images that do not use httpS, this is causing a slight warning "page contains secure and nonsecure items", so this is something you may want to fix.

    Thank you for using our services.