Why my forms are not submitting?

  • Profile Image
    jotformjaimie
    Asked on June 06, 2017 at 12:05 PM

    I paid for the second plan beyond the free plan.  I did this the beginning of this year, and have had nothing but issues with my forms.  Before that I had the free plan.  I made my forms, and I only use a handful, and they are the same, I don't really change them.  I had no problems.  Ever since I upgraded, I have had so many issues with them submitting, I have had to duplicate the forms that were working, and remake them to get them to work, which means my submissions are all over the place now, in different forms.  It's so frustrating.  Now, my form isn't submitting again, I just made this form not too long ago and only have about 10 submissions or less on it, and it's so embarrassing when my clients try to use the forms and all of a sudden they stop working.  What can be done?  I feel like I have paid for nothing.  I get so many submissions and views, and I'm sure I have been the one using up all of those just trying to get these forms to work. I am sure you can understand my frustration, but it's also hard to run a business when my forms won't work, and then it takes me a day or so to get a response for help.  I am on the verge of asking for a refund and moving to another company, as this is just not working for my business model.  I do have proof that the forms are not working, and that I have continually had to contact for help ever since I upgraded.

  • Profile Image
    Kevin_G
    Answered on June 06, 2017 at 01:35 PM

    Apologies for the inconveniences this may have caused to you. 

    I have just checked the form you provided and I can see it works fine, I was able to fill it out and submit the information: 

    I have cleared your forms cache now so the latest version is loaded, could you please check your form and test if it submits? 

    Also, have you embedded your form in a webpage? If so, please share the link with us so we can further check it on our end. 

    If the issue still persists, please open the web console while clicking on the submit button, may be that there is any error or something blocking the resources, these keyboard shorcuts will help you to get the console: 

    Google Chrome:

    Mac: Command + Option + J

    Windows: Control + Shift + J

    Firefox:

    Windows: Ctrl+Shift+K

    Mac: Command+Option+K

    This guide will help you uploading the image with your next reply: How-to-Post-Screenshots-to-Our-Support-Forum

    We will wait for your response.