SMTP Sender: Why emails are no longer sending?

  • Profile Image
    StudioBe
    Asked on June 15, 2017 at 11:33 AM

    JotForm,

    Did your company change servers or something? I am unable to receive ANY form submission emails from ANY of my forms. We send dozens of these internally and nothing is going through. I looked at our history log and it says that all emails are being "sent". However, none are being received. This is not just an internal thing. We also have clients reporting that they are not being received. PLEASE HELP!

    We use mostly custom SMTP senders to send submission emails and we've had multiple problems with this over the last 2 years. We CANNOT use the noreply@jotform email as the sender as it ends up in junk mail folders. Please DO NOT suggest that as an option. 

    The last time we had this issue, I ended up having to contact both the CTO and Founder of your company to get it fixed. I would prefer not to do that again but I need this to be a priority! Please fix this ASAP!!

  • Profile Image
    Kevin_G
    Answered on June 15, 2017 at 01:15 PM

    Apologies for the inconveniences this may have caused to you. 

    We indeed experienced an issue with the SMTP senders; however, this has been already reported and resolved by our developers, I have just tested emails using SMTP sender on my end and I can see it works fine. 

    Could you please test on your end? 

    Please, let us know how it goes. 

     

  • Profile Image
    StudioBe
    Answered on June 15, 2017 at 01:18 PM

    Kevin,

    Ive tested, retested and just tested again. It doesn't work. Not a single notification email, attached to a custom SMTP sender is going through. Its almost all our forms, they are all down!

  • Profile Image
    Kevin_G
    Answered on June 15, 2017 at 02:35 PM

    Could you please share us one of the forms where you experienced the issue? 

    We will be glad  to further check this and forward it to our second level if needed. 

     

  • Profile Image
    StudioBe
    Answered on June 15, 2017 at 03:57 PM

    https://form.jotformpro.com/42026200943948

    This is just one of the forms. All that had custom SMTP senders are broken. Again.

  • Profile Image
    david
    Answered on June 15, 2017 at 05:57 PM

    SMTP emails should be working at this time.  I tested with a couple of my own forms and the emails are triggering almost instantly.  Let us know if they are still not coming through and we will be happy to have another look.