Payment section is not showing up on form.

  • Profile Image
    cohe
    Asked on June 20, 2017 at 01:24 PM

    When I build form and add products I can see "My Products".  When I preview the form "My Products" disappear.  This is not true for my other forms built earlier.  I have examined my set up for "My Products" and it is exactly the same as my other forms where I can visually see the "My Products".  I can't understand what has changed and why they aren't visual now.

  • Profile Image
    Kevin_G
    Answered on June 20, 2017 at 03:26 PM

    Apologies for the inconvenience this may have caused to you. 

    I have checked your form and I can see the issue, I have also cloned your form and I can see the same issue on my end even after deleting the payment section and adding a new payment gateway. 

    I can see the payment integration is not set to be hidden and there are not conditions that may be affecting the payment field, the form settings seem to be the default ones as well. 

    I have also tested with other forms and I can see this works fine, the issue seems to happen with this form only. I will report the issue to our second level so our developers can take a look on it, we will let you know as soon as we get any update about it. 

     

  • Profile Image
    cohe
    Answered on June 21, 2017 at 02:11 PM

    Thank you.  If the answer is to delete and start over - let me know.  We have not published this form yet.  Still working on the final draft.  We wish to publish within the next day or so.

  • Profile Image
    Kevin_G
    Answered on June 21, 2017 at 03:08 PM

    I already tested deleting the payment section and even deleting all the fields on the form, but the issue still persists even when only the payment section was added to the form. 

    I checked the form, yours and my cloned one, using our API and I can see the payment section is indeed listed there, but for some reason it does not appear when previewing the form, I already provided this information in the ticket I opened for this bug, hopefully we will be updated soon. 

     

  • Profile Image
    Rose
    Answered on June 22, 2017 at 01:45 AM

    We are sorry for this inconvenience. 

    I was informed by the developer who was assigned to this ticket. The issue should be fixed now. When I checked your form, I was able to see payment field on the preview. 

    Please also check on your side and let us know if the issue still persists on your side. Do not hesitate to contact us for any further assistance you need from our side.