What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Revision History: Restoration messed up my form

    Asked by OVUForms on June 26, 2017 at 02:16 PM

    So I start out setting up a new form by editing a clone of a previous form. As I am working through, making edits I make a mistake that I wanted to go back and fix. I click on the revision history option, click-back a couple of versions and attempt to continue working.

    The first thing I run into is that I can't get out of Revision Preview Mode (a situation that I later found partially addressed here).
    Okay, very frustrating, but I'll just click back to the Jotform home page and try to re-edit the form... except when I get back to my form, suddenly it LOOKS DIFFERENT on the front-end and the back-end... as if new code has mysteriously been added (or removed?) from my form. I don't even know where to begin. I tried going back into the revision mode, but the problems still exist and now permeate all the versions I have attempted to go back to. WHAT THE HECK???

    First off, my form has some weird new box-shadow added to it...

    NONE of my forms have this box-shadow on it and then for some reason after using the revision history this element now appears on my form. Okay, so my first thought is, that this is probably a quick fix in the code... I don't know why it was added, but I can probably fix it... so I go into the Advance Designer to have a look and here everything is out of wack... the form, which more-or-less should look like the image above in Advance Design mode now looks like this:

    Nothing looks right here--none of my code is implemented, fields are misaligned and don't appear as they should. I don't know where to begin. Why would going back a couple of steps in the revision history make my form into something it has never looked like? What happened?

    I'd like this to get figured out for me and anyone else that might run into this... in the meantime though I'm going to need to start from scratch and redo this form because I don't have time to wait on this to get fixed.

    ------------------------

    EDIT - screenshots did not originally show up in posting

    Page URL:
    https://form.jotformpro.com/71764599441973

  • Profile Image
    JotForm Support

    Answered by BJoanna on June 26, 2017 at 03:39 PM

    Sorry for inconvenience this may caused you.

    Is this the original form http://www.jotformpro.com/form/71766004641958?

    I have cloned and inspected both forms and I noticed that they have different Themes. Did you maybe changed the theme of the cloned form? Also it seems that some lines of custom CSS code that you added to the form are removed from cloned form. Did you remove some CSS code?

    Can you provide us exact step of changes you made, so that we can try to replicate the issue? 

    Also have you tried to revert your form from My Forms folder? I have inspected revision history of your form and it seems that after sixth update style of the form was changed. 

    You can try to revert your form to that version to see if that will resolve your issue. 

    Regarding the issue - 'The first thing I run into is that I can't get out of Revision Preview Mode (a situation that I later found partially addressed here).'

    I was able to replicate it on my end. I have created the separate thread for that issue and I will report it to our developers:

    https://www.jotform.com/answers/1184100 

  • Profile Image

    Answered by OVUForms on June 26, 2017 at 04:29 PM

    When you ask for the "original form" do you mean the form that I cloned to set this one up?

    The form you linked above is actually my new version of the form since I needed to plow forward with setting it up. So here is what we have:

    CLONED Form: http://www.jotformpro.com/form/71234017641952

    PROBLEM Form: https://form.jotformpro.com/71764599441973

    NEW Form: http://www.jotformpro.com/form/71766004641958

    Just to be clear, the cloned form was just a starting point, I edited the CSS to get it closer to the way it now appears on my NEW form. There were no problems there. The problem occurred when I made a type error and tried to use revision history to fix it. The exact steps were as follows:

    -----

    1. Create cloned form

    2. Edit cloned form

    3. Make text mistake

    4. While still in the form builder, I click on the little green revision button (circle arrow icon next to time stamp) at the top of the screen to fix the mistake

    5. Click back a version or two and hit the "Revert" button

    6. Everything looks fine except I can't get out of Revision Preview Mode

    7. Click the Jotform logo at the top of the page to take me back to my Jotform homepage. I'm figuring that whatever happened with the Revision Preview mode must have been a hiccup and I should be able to just get right back into my form.

    8. Go in to edit the form and see immediately that my form does not look right. There is now a box shadow element around my form.

    9. Not happy, but figure I can fix it with a quick css edit so I go into the Form Designer and go to Advance Designer...

    10. That is when I realize more has happened to my form than a little box-shadow.

    11. I tried a few more times to revert back to previous versions to no avail. Even used the alternate method of entering revision history, but it seemed the problem was already baked in at that point.

    -----

    You mentioned that the forms you looked at had different themes. I think that is the problem... They did not originally have different themes nor did I change the themes. The problem occurred when I attempted to make a revision and got stuck in Revision Preview Mode. And then after that, I couldn't revert back to a version that didn't have the theme out of wack.

  • Profile Image
    JotForm Support

    Answered by Mike on June 26, 2017 at 06:56 PM

    Thank you for your detailed reply.

    I have escalated a bug report ticket about the issues with the Revision History tool.

    We will get back to you if we have any updates from our developers.