What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    The hour field in the Date Picker's Time field is blank when Time Format is set to AM/PM

    Asked by nuparadygm on July 01, 2017 at 09:05 AM

    The date/time field is configured with auto insert of "current date and time". However, the form complained and required us to enter valid time. This error is intermittent.

     

    Please advise.

    Page URL:
    https://form.jotform.me/53090740128450

    https://form.jotform.me/53100701860442 

     

    This error happened before.

    Page URL:
    https://form.jotform.me/53090740128450

  • Profile Image
    JotForm Support

    Answered by Jim_R on July 01, 2017 at 03:56 PM

    I can see this same problem even on a cloned copy of your form. It looks like the Hour Field on the Date Picker shows blank when you set the DEFAULT TIME to CURRENT. This also happens when I set the time manually to 0:XX.

    I've escalated this to our Devs and although I won't be able to give you any timeframe, rest assured, we'll keep you apprised on this same thread when there's an update.

    For the meantime, if it's imperative for you to get the CURRENT TIME, you have 2 options:

    1. Either use the 24 HOUR Time Format instead of AM/PM.

    2. Or, remove the TIME option on the Date Picker Field then add a standalone Time Field instead.

  • Profile Image
    JotForm Support

    Answered by NeilVicente on July 03, 2017 at 04:07 AM

    @nuparadygm

    We have fixed this with a patch released the same day this ticket was opened.

    Can you please let us know if you're still having issues?