I have a problem with conditional logic!

  • Profile Image
    embajadoresizettle
    Asked on July 06, 2017 at 11:14 AM

    I have a form where, if people select either one of two checkboxes, I need to ask them an additional question--phone company. So, I'm using conditional logic to hide the "phone company" field until they select ANY of the two boxes. In theory it should work, but in practice, only the field CLOSEST to the rule obeys the logic. The top field in the image below does not. I tried switching their places, and the issue remains: whichever condition I place closer to the rule obeys the rule, the other does not. Any help you can provide would be a huge help, thank you!

     

     

  • Profile Image
    BDAVID
    Answered on July 06, 2017 at 01:08 PM

    Please re-calibrate your conditions to this:

    That will solve the issue, you can test it in my clone version: https://form.jotformpro.com/71865282580968 

  • Profile Image
    embajadoresizettle
    Answered on July 06, 2017 at 01:57 PM

    Hi, thank you! Your test version works except that when I first load the form I can see the "Telefonía" field at the bottom. Earlier today, I tried to keep it hidden by applying both the rule you sent and the rule I sent you, but it didn't work that way either. Do you have a suggestion for how to keep that field hidden? 

    Thanks again.

  • Profile Image
    BDAVID
    Answered on July 06, 2017 at 02:42 PM

    You need to remove the field from the following condition:

    Example(ctrl + click on it to deselect):

    Try my clone example again, the field will show up only if one of the specifics options is selected.