Form Fields: Fields are getting the word "DISABLED" added to their name when certain string is used.

  • Profile Image
    jtate
    Asked on July 12, 2017 at 02:01 PM

    There is a form with the option that says "Person submitting recommendation" and once submitting it, that section is left blank. We can't figure out how to fix it. 

     

    https://www.jotform.com/build/50426278539967 

     

    This is the form 

  • Profile Image
    Kevin_G
    Answered on July 12, 2017 at 03:34 PM

    I have been testing your form and I can see it is saving the submitted data in the field "Person submitting recommendation".

     Could you please check on your end and confirm that you see the submitted data too? 

    If this issue happens on a different feature, such as email notifications, please let us know. 

  • Profile Image
    jtate
    Answered on July 13, 2017 at 11:26 AM

    Hello! 

     

    Yes so the problem is with the email notifications. Attached is an example of the email notification, without the name of the "person submitting the recommendation" 

    When looking back at the form, in settings, emails the space for Person submitting recommendation appears with a DISABELED and although I have erased that, it continues to appear every time. 

     

     

  • Profile Image
    Kevin_G
    Answered on July 13, 2017 at 12:48 PM

    I have tested this and noticed the same you are reporting, the word "DISABLED" is being added, but it seems to happen only when the field's name is "personsubmittingrecommendation". I would suggest you to change the field's name to something else, as an example you may use "submitter" as field name. 

    This guide will help you to find it: https://www.jotform.com/help/146-How-to-Find-Field-IDs-and-Names 

    Please, make sure to update it in the email template too. 

    I will also forward this to our second level so our developers can further investigate the issue, we  will let you know as soon as we get any update about it. 

     

  • Profile Image
    jtate
    Answered on July 14, 2017 at 10:35 AM

    Hello! 

    I tried this and it's not working. Should I create a new form? I don't know what else to do. 

  • Profile Image
    Kevin_G
    Answered on July 14, 2017 at 12:04 PM

    It is not needed to create a new form, I have checked your form and noticed you have updated the field's name: 

    On the email template I can see the field's name has some HTML tags, this is why it's not submitting any value: 

    However, I have already removed the HTML tags and the style code form your email template so the field's value should be included in the email now. Please, check your emails and let us know if the field still is blank.