What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Why my form is stuck on please wait on submit?

    Asked by Roger Brealey  on July 14, 2017 at 08:22 PM

    I am a NEWBIE

    My newly created form is hanging after submitting. the submit button changes to "please wait", and nothing is happening. I would be expecting a thank you page (default page).

    also i have a condition when a "No" is clicked another entry section is supposed to action. works fine in preview mode when building form, but does not when Live. Below is the the question. 

    Would you re-book Golden Memories Karaoke sessions? *

     Yes, definitely (we would pay $100) Would only re-book if receiving council support No, we would not re-book  

    https://form.jotform.co/71946964061868

     

    PLEASE NOTE THE ABOVE PROBLEMS ARE WITH GOOGLE CHROME. I COULD NOT SEND THIS QUESTION VIA CHROME. HAVE HAD TO USE WINDOWS EXOLORER

    Please Investigate and advise.

    Thanks

    Roger Brealey

    Australia

    email me at rogerbrealey@kern.com.au

     

  • Profile Image
    JotForm Support

    Answered by Nik_C on July 15, 2017 at 02:32 AM

    I tested your form and I was able to submit it:

    So I assume that this issue is happening because your form is embedded in your website.

    If that's the case please try re-embedding your form by using the below iFrame code:

    <iframe id="JotFormIFrame-71946964061868" onload="window.parent.scrollTo(0,0)" allowtransparency="true" src="https://form.jotform.co/71946964061868" frameborder="0" style="width:100%; height:0px; border:none;" scrolling="no"> </iframe>

    So simply replace the existing code with the above one.

    Regarding the condition for "No". I checked all fields and they were acting fine, but again, it might happen only when embedded.

    So please try the above code and let us know how it worked.

    Thank you!

  • Profile Image

    Answered by Roger Brealey on July 15, 2017 at 02:48 AM

    I tried it on a laptop win 7 with chrome, all good. I was having problems on Desk Top windows 10.

    i cleared the cache and all seemed OK. i thin though that i did have to clear the cache several times. also i thing it might have been me as I think I might not have been 'Publishing. regarless id soes not explain why i could not send "this original enquiry via Chrome" on my desktop.

    i have not embedded all i will be doing is sending the published link in an email.

    thank you for your attention.

  • Profile Image
    JotForm Support

    Answered by Welvin on July 15, 2017 at 07:37 AM

    You're welcome. That confirms that the problem is on your Windows 10 PC. You may consider reinstalling Google Chrome and make sure to choose the stable version instead of the advanced build.