Not receiving submission email after form is submitted.

  • Profile Image
    Flyinfur
    Asked on July 16, 2017 at 07:44 PM

    I used the iFrame code and tested the form from a friend's computer. The form went through (I received the "thank you for your submission" message), but I didn't received an email with the form. What now?!



    This is a re-post of a comment on Getting the Form iFrame Code

  • Profile Image
    ashwin_d
    Answered on July 16, 2017 at 10:48 PM

    Hello,

    I'm sorry for the trouble caused to you. 

    I did check your form's notification email alert and did not find any issue with that. You have configured it correctly and you should receive submission emails without any problem. I also checked our email logs and found submission email was sent successfully. Please check the log below:

    [2017-07-16 19:02:45] Submission #3760553628816623349 Form #71718223856158 SENT to flyinfur1@comcast.net from noreply@jotform.com, via SENDMAIL 

    Have you checked your SPAM folder already? Please check your SPAM folder and see if the submission emails ended up there. If the issue persists,  I would suggest you to please use your own email address with SMTP settings to send submission emails. You may like to take a look at the following guide on how to use your own SMTP setting:  https://www.jotform.com/help/244-How-to-Setup-SMTP-for-a-Form 

    Hope this helps.

    Do get back to us if the issue persists.

    Thank you!

  • Profile Image
    Flyinfur
    Answered on July 23, 2017 at 08:23 PM

    I have checked my spam folder in both by Outlook and with the Comcast email system and there are no emails from jotforms there.  I have also changed to using my own email address in the SMTP settings and still NO LUCK.  I just can't figure out if I'm doing something wrong (user error) or if jot forms just doesn't like me.  LOL!  I appreciate the assistance you have already provided, but could really use some more help.  Thanks, in advance, for anything you can do to help me.  :-)

  • Profile Image
    John_Benson
    Answered on July 24, 2017 at 02:21 AM

    Please try to contact your email provider and request them to add JotForm's IP addresses to their whitelist. For more information regarding on domain names and IP address list, please visit this link: https://www.jotform.com/help/145-Whitelisting-JotMails-IP-Addresses

    After that, please try to fill up your form manually and click the Submit button to check your notification email if it's working properly. 

    Let us know how it goes. Thank you.