Why Submit button hangs on "Please wait"?

  • Profile Image
    isbitt
    Asked on July 21, 2017 at 11:31 AM

    Hi,

    Users have reported issues where forms are completed and once they press submit, the box hangs on 'Please wait' and the form isnt sent

    Please can you confirm if this is a Jotform server issue and how we can look to resolve the issue ?

    Thanks

    Richard

  • Profile Image
    Nik_C
    Answered on July 21, 2017 at 01:49 PM

    We're sorry for the inconvenience.

    Could you please provide the Form ID and if the form is embedded in a website, please provide the URL of the website.

    So we can investigate further.

    We'll wait for your response.

    Thank you!

  • Profile Image
    isbitt
    Answered on July 24, 2017 at 04:43 AM
    Morning
    Please find the form link below
    Thanks
    https://form.jotformeu.com/isbitt/credit-request-form
    _________________________________________
    Richard Isbitt
    Group Billing and Master Data Manager
    Sthree PLC
    8th Floor
    City Place
    55 Basinghall Street
    London
    EC2V 5DX
    •: +44 (0) 207 264 3573
    • Internal 246 7573
    ___________________________
    ...
  • Profile Image
    ashwin_d
    Answered on July 24, 2017 at 08:52 AM

    Hello Richard,

    I'm sorry for the trouble caused to you. 

    The URL which you have shared is direct custom URL of your form. I believe you have not embedded your form in any webpage. Is that correct?

    I did test your form and I am unable to replicate the issue you are having. I was able to submit your form successfully and thank you message was also displayed successfully. Please check the screenshot below:

     

    I would suggest you to please test your form again and get back to us if the issue persists. 

    We will wait for your response.

    Thank you!

  • Profile Image
    isbitt
    Answered on July 24, 2017 at 09:43 AM
    Thanks for reviewing this
    The form is not embedded on a website, its standalone link that users save on the browser
    It happens now and then so it will likely work for your test. However 2 separate users today have raised it as an issue, its like the form disconnects. Does it time out once its opened and the user hits the send button ?
    _________________________________________
    Please provide feedback on how we can improve our service
    (30 secs to complete):
    https://form.jotformeu.com/70032022466342
    Richard Isbitt
    Group Billing and Master Data Manager
    Sthree PLC
    8th Floor
    City Place
    55 Basinghall Street
    London
    EC2V 5DX
    •: +44 (0) 207 264 3573
    • Internal 246 7573
    ___________________________
    ...
  • Profile Image
    aubreybourke
    Answered on July 24, 2017 at 10:51 AM

    I tested it again just now. It took like ten seconds saying "Please wait..."

    But it went through. And I got the thank you page:

  • Profile Image
    isbitt
    Answered on July 25, 2017 at 03:43 AM
    Hi,
    Thanks for your reply
    Sometimes it just says please wait and doesn’t move on. What is causing this delay and can we do anything about it ? maybe even save the form and re-send at a later date ?
    Thanks
    _________________________________________
    Please provide feedback on how we can improve our service
    (30 secs to complete):
    https://form.jotformeu.com/70032022466342
    Richard Isbitt
    Group Billing and Master Data Manager
    Sthree PLC
    8th Floor
    City Place
    55 Basinghall Street
    London
    EC2V 5DX
    •: +44 (0) 207 264 3573
    • Internal 246 7573
    ___________________________
    ...
  • Profile Image
    ashwin_d
    Answered on July 25, 2017 at 05:11 AM

    Hello Richard,

    I again tested this issue and I am unable to replicate the issue. I was able to submit your form successfully without any problem. 

    When this issue happens again, please share the screenshot of the browser console message and we will take a look. Please check the screenshot below on how to check the browser console:

     

    Thank you!

  • Profile Image
    isbitt
    Answered on August 07, 2017 at 10:43 AM
    Hi there
    As below
    Would you mind clarifying why we cannot access the uploaded documents on the Jotform. I would log this on the internet but thought it was easier to forward on the screenshots etc
    The form used was called “Credit Request Form”

    Thanks
    Richard
    _________________________________________
    Richard Isbitt
    Group Billing and Master Data Manager
    Sthree PLC
    8th Floor
    City Place
    55 Basinghall Street
    London
    EC2V 5DX
    •: +44 (0) 207 264 3573
    • Internal 246 7573
    ___________________________
    ...
  • Profile Image
    Nik_C
    Answered on August 07, 2017 at 12:03 PM

    I moved your last question to this thread: https://www.jotform.com/answers/1217583 since it is unrelated to the original issue.

    Thank you!