What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Show/hide conditions issue

    Asked by DavidVerissimo on August 15, 2012 at 10:03 AM

    Why doesn't the show/hide conditions work when the fields they relate to are all in the same page?

    Page URL:
    http://form.jotformeu.com/form/21285842316352

  • Profile Image

    Answered by ItalyTech on August 15, 2012 at 10:04 AM

    Hi, can you indicate us your form ID please ?

    Thanks.

     

    Alessandro

  • Profile Image

    Answered by DavidVerissimo on August 15, 2012 at 10:07 AM

    Hey, thanks for the quick response. I already added the url.

  • Profile Image

    Answered by DavidVerissimo on August 15, 2012 at 10:10 AM

    The field "2 MARCA (Preencha apenas se aplicável)" and "2 MODELO (Preencha apenas se aplicável)" on the second page were supposed to be hidden when the answer to the question "Quantos artigos tem para troca?" was 1 but they don't.

  • Profile Image

    Answered by ItalyTech on August 15, 2012 at 10:23 AM

    Hi, I've edited your conditions.

     

    Can you test again your form and let us know if it works good now ? :)

     

    Thanks.
    Alessandro

  • Profile Image

    Answered by DavidVerissimo on August 15, 2012 at 10:34 AM

    I don't know if you guys did anything but the problem was solved  :) Thanks

    But it seams i now have a different problem. When "Quantos artigos tem para troca?" answer is superior than 1, the field "2 MARCA (Preencha apenas se aplicável)" and "2 MODELO (Preencha apenas se aplicável)" was supposed to appear but they don't. The same thing happens to the third field. I mean, When "Quantos artigos tem para troca?" answer is superior than 2, the field "3 MARCA (Preencha apenas se aplicável)" and "3 MODELO (Preencha apenas se aplicável)" was supposed to appear but they don't.

    Can you help me out?

     

    Thanks

  • Profile Image

    Answered by ItalyTech on August 15, 2012 at 10:46 AM

    I suggest you to clear your browser because now your form works good for me.

     

    Your form now works good becuase I've changed your conditions.

     

    I've added this conditions:

    if "Quantos artigos tem para troca?" equals to 2 then

    HIDE 3 modelo and 3 marca fields

    and

     

    if "Quantos artigos tem para troca?" equals to 1 then

    HIDE 3 modelo and 3 marca fields.

     

    You've forgot to add this conditions I think :)

    Hope this helps.


    Alessandro

  • Profile Image

    Answered by DavidVerissimo on August 15, 2012 at 11:01 AM

    Thank you for your work my friend but the fields "2 MARCA" and "2 Modelo" still don't appear when "Quantos artigos tem para troca?" is 2. The fields "3 MARCA" and "3 Modelo" also don't appear when "Quantos artigos tem para troca?" is 3...   :o(

    I double check this on different browsers. Are you sure the fields appear correctly in your browser? What is the browser you use?

  • Profile Image

    Answered by ItalyTech on August 15, 2012 at 11:18 AM

    I've tested it with Firefox and IE 8 and it works good on my side.

    I can attach you a screenshot if you want :)

     

    Alessandro

  • Profile Image

    Answered by DavidVerissimo on August 15, 2012 at 11:33 AM

    Ok, i see the problem now...

    Maybe this will help someone with the same issue in the future:

    For the conditions to work, the person who is responding has to use the KEYBOARD to input the number on the box. He can't use the litlle arrows on the side of the box.

    I will have to delete the "Number" quick tool and replace it by a text box (using a numeric validation) so that the up/down arrows don't appear because if the client decides to use them the conditions will not work.

    Thank you once again for your help Alessandro! You guys rock!

  • Profile Image

    Answered by ItalyTech on August 15, 2012 at 11:35 AM

    Now I understand...

     

    I've used keyboard and I was going crazy because I can't reproduce this error you got :)

     

    I hope I helped you.

     

    Alessandro

  • Profile Image

    Answered by pinoytech on August 15, 2012 at 11:45 AM

    Hi David,

    I have made some workarround of your form's conditions and this what I have: http://jotform.me/form/22274820452449? .

    Is this the kind of form's condition that you want to achieved? If you like what I did, feel free to clone the form. By the way, I change "Number" field to "Spinner" field that can be found under Survey Tools.

    Thank you!

  • Profile Image

    Answered by DavidVerissimo on August 15, 2012 at 12:00 PM

    Awesome! That's exactly what i wanted. You're right! I should have used a spinner! My mistake.

    I would clone the form but i have the URL of my form on several sites so i if clone your form i would have to change all of the links right?

    If this is the case and if the problem was just the fact that i didn't use a spinner then i can just do the changes myself. The spinner was the only problem?

  • Profile Image

    Answered by pinoytech on August 15, 2012 at 12:40 PM

    Hi again David,

    Sorry for the late response and good to hear that you like what I did.

    Yes, if you want to use the form that I have fixed you need to update each of your website where your form code embedded by embedding with the new form's code. You can however change the fields of your form and update your form's condition with this condition:

    If you need further assistance, feel free to contact us anytime.

    Thank you!

  • Profile Image

    Answered by DavidVerissimo on August 15, 2012 at 12:54 PM

    I don't know how to thank you man. I finally get the logic os this. PrintScreens leave no room for error  :)  I should only state what i want to SHOW in the diferrent options rather than state what i want to HIDE.

    Problem solved!

    Thanks a million

  • Profile Image

    Answered by pinoytech on August 15, 2012 at 01:02 PM

    You are always welcome david! I am happy that you like what I did and thank you for your cooperation.

    If you need our assistance again, feel free to contact us at anytime.

    Have a good day!