Import Data App: XLS template format is broken

  • Profile Image
    OneStart
    Asked on July 26, 2017 at 07:10 AM
    I have tried to import our data to a clone form following the instruction of https://www.jotform.com/help/308-Import-App-Easily-import-your-Excel-or-CSV-data-into-JotForm

    I have changed all the title, CSV/ excel form and it just left me:Error: The File could not be uploaded. No Submissions created.

    Please check you can find out the problem or mistake that I have made.

     

  • Profile Image
    Kiran
    Answered on July 26, 2017 at 11:44 AM

    I have checked the Import submissions app on a test form. It is working fine at my end.

    If you are uploading Excel file, please make sure that it in .xls format. Also, please see that the headers of the file being uploaded as in the template format provided in the Import app. The headers of the file should match to the template in order to have the successful import.

    Please give it a try again and let us know if you need any further assistance. We will be happy to help. 

  • Profile Image
    OneStart
    Answered on July 27, 2017 at 06:49 AM

    I have duplicated a current form and download an excel file from it to test the app.

    To match the data sequence, I have deleted the first 4 columns.

    Also, the headers are already changed according to the tool and .xls & .csv are tested.

    But the result is still an error.

    Please check the photo to see if I have done something wrong.

     

  • Profile Image
    Kiran
    Answered on July 27, 2017 at 11:06 AM

    Could you provide us with the Excel file and the form ID so that we can try replicating the issue at my end? You may send the excel file to support@jotform.com with the subject line 'Support forum - 1208756'. Please let us know here after sending the email so that we can take a look further.

    We will wait for your response. Thank you! 

  • Profile Image
    Kiran
    Answered on August 08, 2017 at 07:42 AM

    I am sorry for the delay. I have cloned the form http://www.jotform.me/form/62661952480460 to my account to import the submissions. I have checked the Excel file that you have sent to us and see that some of the fields on the form are not matching to the columns in the spreadsheet. As I tried to import the submissions file using Excel format, the format template is displaying the columns up to AR1 only. However, I tried to match the fields using CSV format by adjusting the columns in Excel which didn't work. I'll give another try when I have got some free time. 

    Here is the CSV file that I was working on, if you want to give a try on a cloned form. 

    http://shots.jotform.com/kiran/shared/1208756.csv

    Please note the fields in the CSV file should match the names in the template.

    I'll get back to you if I am able to have any news in this regard. 

    Thank you for your patience and understanding.