What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Reply-To does not work

    Asked by deepcreek on August 15, 2012 at 08:19 PM

    My gmail account does not want to use the Reply-To field that I have set in the jotform.  In comparison to other emails that have the Reply-To form, I notice that jot form uses a lower case "to" like this:

     

    Reply-to

    where other emails that do work gmail use an upper case "To" like this:

    Reply-To

     

    Could that be a bug in your code?

     

    Please advise

    Page URL:
    http://www.deepcreekcloud10.com/requestinfo2.htm

  • Profile Image

    Answered by jeanettebmz on August 15, 2012 at 09:05 PM

    I just made a test using my gmail account and I could not reproduce the problem . I was able to reply to another gmail address that I created for that purpose .


     

    And this my gmail inbox and the Reply to screen

     

    I would recommend you delete and re-create your email alert, and then leave the Sender field set to noreply@jotform.com

  • Profile Image

    Answered by deepcreek on August 15, 2012 at 09:14 PM

    Try this.

     

    Jot form goes to gmail account 1

    gmail account 1 forwards to gmail account 2

    You reply to the jot form notification in gmail account 2 but the reply goes to gmail account 1 instead of the jotform reply-to address.

    I have other emails that are forward to gmail account 2 from gmail account 1 and they respond correctly to the Reply-To field.

    That is my case.

  • Profile Image
    JotForm Support

    Answered by idarktech on August 15, 2012 at 10:51 PM

    @deepcreek,

    Thanks for your clarification. Unfortunately, our Reply-To feature can't work that way. It would only work to the address where it was sent to.

    Forwarding the submission is another case here. It's not an issue with JotForm anymore but instead with your email service provider and that's how email system works. When you forward a message, your email service provider (which was gmail I guess) would automatically catch the sender address and set it as a reply to address when you will reply to the forwarded message.

    Hope this clarifies a bit. Thank you for asking and have a pleasant day!

  • Profile Image

    Answered by deepcreek on August 15, 2012 at 10:59 PM

    Actually, you are incorrect.  How do I know?  Because VRBO.com sends an inquiry form to my gmail account 1 which forwards that to my gmail account 2.  I hit reply in my gmail account 2 and the original person's email address is who is now in the To field, not the gmail account 1 or vrbo.com.  I found the difference in the headers from my vrbo.com email form and from your form which seems to have gone unnoticed.  I will paste the headers here for you to see.

     

    This works

    From: "VRBO.com" <inquiry@vrbo.com> Reply-To: Carol James <clifjams@gmail.com> To: skiandglee@gmail.com Message-ID: <53a1535a4cec4b9586ac7436115005b4-62789.inquiry-contact@homeaway.com> Subject: Inquiry from Carol James - Aug 5 to 12 - Listing #340554 MIME-Version: 1.0 Content-Type: multipart/related; boundary="----=_Part_828391_639370757.1329685496261" X-Inquiry-ID: 53a1535a4cec4b9586ac7436115005b4 X-Inquiry-TravelerSource: vrbo X-Inquiry-ListingSource: vrbo X-Inquiry-Listing: vrbo-340554

    This does not work
    To: deepcreekcloud10@gmail.com Subject: Cloud 10 Rental Inquiry X-PHP-Originating-Script: 1002:PHPMailerLite.php Date: Wed, 15 Aug 2012 20:14:28 -0400 From: Test Tester <skiandglee@gmail.com> Reply-to: Test Tester <skiandglee@gmail.com> Message-ID: <711d4e5c50d093aea8d94514eea3311e@submit.*> X-Priority: 3 X-Related-FormID: 22277741003143 X-Related-UserName: NoUserName X-Related-Last-Form-ID: X-Related-IP: 71.191.77.81 MIME-Version: 1.0 Content-Transfer-Encoding: 8bit Content-Type: text/html; charset="utf-8"

    I hope this clarifies a bit.
  • Profile Image
    JotForm Support

    Answered by idarktech on August 15, 2012 at 11:29 PM

    Thanks for your prompt response.

    I will now forward this to our developers so they can further investigate this issue. We will update you via this thread once we heard back from them or they may be the one to reply here in this thread.

    Again, thank you for your explanation, we appreciate it much!

  • Profile Image
    Chief Technology Officer

    Answered by eee on August 16, 2012 at 07:05 AM

    Hi,

    Problem was related with a bug in PHPMailerLite,

    It is solved now,

    Thank you for reporting,

    Kindest Regards,

    Ertuğrul.

  • Profile Image

    Answered by deepcreek on August 16, 2012 at 08:26 AM

    Unfortunately this hasn't fixed the reply problem.  The Reply-To is now formatted properly but it is still replying to the account it came from rather than the reply-to.  This is not the case with the vrbo.com emails that I reply to so perhaps it is one of the X-headers so I am listing the entire header below.  The reply should go to skiandglee@gmail.com but instead goes to deepcreekcloud10@gmail.com.

     

    Delivered-To: contact.rickmc@gmail.com
     Received: by 10.76.142.70 with SMTP id ru6csp130230oab;
     Thu, 16 Aug 2012 05:19:48 -0700 (PDT)
     Received: from mr.google.com ([10.182.46.65])
     by 10.182.46.65 with SMTP id t1mr985264obm.20.1345119588328 (num_hops = 1);
     Thu, 16 Aug 2012 05:19:48 -0700 (PDT)
     Received: by 10.182.46.65 with SMTP id t1mr793700obm.20.1345119588311;
     Thu, 16 Aug 2012 05:19:48 -0700 (PDT)
     X-Forwarded-To: contact.rickmc@gmail.com
     X-Forwarded-For: deepcreekcloud10@gmail.com contact.rickmc@gmail.com
     Delivered-To: deepcreekcloud10@gmail.com
     Received: by 10.182.90.199 with SMTP id by7csp28920obb;
     Thu, 16 Aug 2012 05:19:47 -0700 (PDT)
     Received: by 10.229.136.144 with SMTP id r16mr568047qct.152.1345119587244;
     Thu, 16 Aug 2012 05:19:47 -0700 (PDT)
     Return-Path: <noreply@jotmails.com>
     Received: from ying.jotservers.com (ying.jotform.com. [174.34.57.214])
     by mx.google.com with ESMTP id l15si2116679qct.102.2012.08.16.05.19.47;
     Thu, 16 Aug 2012 05:19:47 -0700 (PDT)
     Received-SPF: pass (google.com: domain of noreply@jotmails.com designates 174.34.57.214 as permitted sender) client-ip=174.34.57.214;
     Authentication-Results: mx.google.com; spf=pass (google.com: domain of noreply@jotmails.com designates 174.34.57.214 as permitted sender) smtp.mail=noreply@jotmails.com
     Received: from ying.jotservers.com (localhost [127.0.0.1])
     by ying.jotservers.com (8.14.3/8.14.3/Debian-5+lenny1) with ESMTP id q7GCJktw006834
     for <deepcreekcloud10@gmail.com>; Thu, 16 Aug 2012 08:19:46 -0400
     Received: (from jotform@localhost)
     by ying.jotservers.com (8.14.3/8.14.3/Submit) id q7GCJk4j006833;
     Thu, 16 Aug 2012 08:19:46 -0400
     X-Authentication-Warning: ying.jotservers.com: jotform set sender to noreply@jotform.com using -f
     To: deepcreekcloud10@gmail.com
     Subject: Cloud 10 Rental Inquiry
     X-PHP-Originating-Script: 1001:PHPMailerLite.php
     Date: Thu, 16 Aug 2012 08:19:46 -0400
     From: test tester <skiandglee@gmail.com>
     Reply-To: test tester <skiandglee@gmail.com>
     Message-ID: <ac8837c47aec338296fa0ecb793c7c59@submit.*>
     X-Priority: 3
     X-Related-FormID: 22277741003143
     X-Related-UserName: NoUserName
     X-Related-Last-Form-ID:
    X-Related-IP: 71.191.77.81
     MIME-Version: 1.0
     Content-Transfer-Encoding: 8bit
     Content-Type: text/html; charset="utf-8"
  • Profile Image
    Chief Technology Officer

    Answered by eee on August 16, 2012 at 08:30 AM

    Hi,

     X-Forwarded-To: contact.rickmc@gmail.com
     X-Forwarded-For: deepcreekcloud10@gmail.com contact.rickmc@gmail.com

    These lines are added by your service provider, we can not change them! 

    Please contact with your provider to solve the problem or try to use to set noreply@jotform.com as a sender email.

    Kindest regards,

    Ertuğrul.

  • Profile Image

    Answered by deepcreek on August 16, 2012 at 08:33 AM

    That must not be the problem.  Below is a vrbo.com inquiry form that does the exact same thing.  It is sent to gmail account 1 and that forwards to gmail account 2 and when I reply from gamil account to, it goes to the reply-to address.  It also has the x-forwarded-to flags.

     

    Delivered-To: contact.rickmc@gmail.com
     Received: by 10.76.142.70 with SMTP id ru6csp127307oab;
     Thu, 16 Aug 2012 04:47:00 -0700 (PDT)
     Received: from mr.google.com ([10.224.138.78])
     by 10.224.138.78 with SMTP id z14mr3107184qat.39.1345117620831 (num_hops = 1);
     Thu, 16 Aug 2012 04:47:00 -0700 (PDT)
     Received: by 10.224.138.78 with SMTP id z14mr2485137qat.39.1345117620792;
     Thu, 16 Aug 2012 04:47:00 -0700 (PDT)
     X-Forwarded-To: contact.rickmc@gmail.com
     X-Forwarded-For: skiandglee@gmail.com contact.rickmc@gmail.com
     Delivered-To: skiandglee@gmail.com
     Received: by 10.49.52.7 with SMTP id p7csp5155qeo;
     Thu, 16 Aug 2012 04:47:00 -0700 (PDT)
     Received: by 10.182.110.37 with SMTP id hx5mr670437obb.48.1345117619998;
     Thu, 16 Aug 2012 04:46:59 -0700 (PDT)
     Return-Path: <inquiry@vrbo.com>
     Received: from smtpout1.vrbo.com (smtpout1.vrbo.com. [66.45.49.30])
     by mx.google.com with ESMTP id s9si4142292oea.54.2012.08.16.04.46.59;
     Thu, 16 Aug 2012 04:46:59 -0700 (PDT)
     Received-SPF: pass (google.com: domain of inquiry@vrbo.com designates 66.45.49.30 as permitted sender) client-ip=66.45.49.30;
     Authentication-Results: mx.google.com; spf=pass (google.com: domain of inquiry@vrbo.com designates 66.45.49.30 as permitted sender) smtp.mail=inquiry@vrbo.com; dkim=pass header.i=inquiry@vrbo.com
     DKIM-Signature: v=1; a=rsa-sha1; c=relaxed/relaxed; s=k1; d=vrbo.com;
     h=Date:From:Reply-To:To:Message-ID:Subject:MIME-Version:Content-Type; i=inquiry@vrbo.com;
     bh=fPX1j4aZTtnSEiNZwVgGM/ciSWo=;
     b=fiAbgdMDcCDV4pYC8qIGtMS8u9lSwbWBt70KHLpYR67gPp44oKv6X/3MA1mvGasMxRz5j3/QW5iQ
     VdaKynMhb0OR/x2JS6Yh1jRxZ7Eetcc1k6r0aS+q5b6hBo/+YrsLxXcdEQ/M/j2wmoss3A8OA05b
     4kRB9b653mbTe19G/Jk=
     DomainKey-Signature: a=rsa-sha1; c=nofws; q=dns; s=k1; d=vrbo.com;
     b=CsOEU6PCGm+qvZex4R02WrkKPHpozheBtoqtv7YmPY6pGz6tTKVmGBkoeMXYj8tAnPwIOhtpY3Z6
     ufbstZH/2an/FXIKY6OP9oFEkk7VZpkIuzgj//ck0E858FDk6+MiAwEAsTf8f3OxUVSiYkbY2ZKX
     aGwxuQzwI1c7IEMMMvI=;
     Received: by smtpout1.vrbo.com id h5jer616904u for <skiandglee@gmail.com>; Thu, 16 Aug 2012 06:46:55 -0500 (envelope-from <inquiry@vrbo.com>)
     Date: Thu, 16 Aug 2012 06:46:55 -0500 (CDT)
     From: "VRBO.com" <inquiry@vrbo.com>
     Reply-To: Jennifer Davis <jshereed@gmail.com>
     To: skiandglee@gmail.com
     Message-ID: <17f77ea838d84440af0bc44c34dc8cee-27574.inquiry-contact@homeaway.com>
     Subject: Inquiry from Jennifer Davis - Oct 5 to 8 - Listing #340554
     MIME-Version: 1.0
     Content-Type: multipart/related;
    boundary="----=_Part_12192854_677018804.1345117615536"
     X-Inquiry-ID: 17f77ea838d84440af0bc44c34dc8cee
     X-Inquiry-TravelerSource: vrbo
     X-Inquiry-ListingSource: vrbo
     X-Inquiry-Listing: vrbo-340554
  • Profile Image

    Answered by deepcreek on August 16, 2012 at 09:47 AM

    An update.  Something is definitely wrong and I don't know what.  I decided to try and just send the email notification from jotform directly to my gmail account and see if the "reply-to" or the "from" email address would work correctly.  i.e. bypass the forwarding gmail account.  To my surprise it does not!

    When I hit reply, it goes to the To: adress of contact.rickmc@gmail rather than the reply-to or from address of skiandglee@gmail.  That should not happen.

    Delivered-To: contact.rickmc@gmail.com
     Received: by 10.76.142.70 with SMTP id ru6csp138723oab;
     Thu, 16 Aug 2012 06:43:48 -0700 (PDT)
     Received: by 10.224.18.209 with SMTP id x17mr3259739qaa.15.1345124628691;
     Thu, 16 Aug 2012 06:43:48 -0700 (PDT)
     Return-Path: <noreply@jotmails.com>
     Received: from monk.jotservers.com (monk.jotform.com. [174.34.57.218])
     by mx.google.com with ESMTP id w4si2233816qct.124.2012.08.16.06.43.48;
     Thu, 16 Aug 2012 06:43:48 -0700 (PDT)
     Received-SPF: pass (google.com: domain of noreply@jotmails.com designates 174.34.57.218 as permitted sender) client-ip=174.34.57.218;
     Authentication-Results: mx.google.com; spf=pass (google.com: domain of noreply@jotmails.com designates 174.34.57.218 as permitted sender) smtp.mail=noreply@jotmails.com
     Received: from monk.jotservers.com ([127.0.0.1])
     by monk.jotservers.com (8.14.3/8.14.3/Debian-5+lenny1) with ESMTP id q7GDhmB4022586
     for <contact.rickmc@gmail.com>; Thu, 16 Aug 2012 09:43:48 -0400
     Received: (from jotform@localhost)
     by monk.jotservers.com (8.14.3/8.14.3/Submit) id q7GDhmmX022585;
     Thu, 16 Aug 2012 09:43:48 -0400
     X-Authentication-Warning: monk.jotservers.com: jotform set sender to noreply@jotform.com using -f
     To: contact.rickmc@gmail.com
     Subject: Cloud 10 Rental Inquiry
     X-PHP-Originating-Script: 1002:PHPMailerLite.php
     Date: Thu, 16 Aug 2012 09:43:48 -0400
     From: test test <skiandglee@gmail.com>
     Reply-To: test test <skiandglee@gmail.com>
     Message-ID: <6991d006b34c6a7ccf5570e52fd3eeae@submit.*>
     X-Priority: 3
     X-Related-FormID: 22277741003143
     X-Related-UserName: NoUserName
     X-Related-Last-Form-ID:
    X-Related-IP: 71.191.77.81
     MIME-Version: 1.0
     Content-Transfer-Encoding: 8bit
     Content-Type: text/html; charset="utf-8"
  • Profile Image

    Answered by deepcreek on August 16, 2012 at 09:53 AM

    Here are 2 screen shots.  First one shows that gmail thinks it's from skiandglee and the reply to is skiandglee but screen shot 2 shows that when I hit reply, it wants to go to contact.rickmc which was the destination address, not the from or the reply-to.

     

  • Profile Image

    Answered by deepcreek on August 16, 2012 at 10:09 AM
  • Profile Image

    Answered by deepcreek on August 16, 2012 at 10:35 AM

    After testing all morning, I found the problem and it's not your fault.  It's a bug in Gmail.  They now have multiple account login which they just rolled out recently.  Because all of the emails I have been trying, I have access to them and have them associated with this gmail account, they are defaulting to my primary account rather that the associated account that is stipulated in the reply-to and from address.

    I verified this by putting in random made-up email addresses and even friend's email addresses and each time, the reply-to worked fine.

    Sorry to have put it on JotForm when it was a gmail problem but hopefully this can go in your knowledge base faq's to help others that will undoubtedly come across this issue if they are using gmail accounts.

    Rick

  • Profile Image
    Chief Technology Officer

    Answered by eee on August 16, 2012 at 10:39 AM

    Hi,

    I was about to kill myself while trying to re-create the issue. Now, I may rest in peace :]

    Thank you, Rick,

    Kindest Regards,

    Ertuğrul.

     

  • Profile Image

    Answered by deepcreek on August 16, 2012 at 10:54 AM

    Hi Ertugrul,

     

    Well don't quit just yet.  I figured I would go modify the form and use the as the from and put the correct reply-to email in the notification form on jotform.  When I send the test and hit reply, it goes to and has no reply-to in the headers at all.

  • Profile Image
    Chief Technology Officer

    Answered by eee on August 16, 2012 at 10:55 AM

    Can you send the details of the email ? 

    - Ertuğrul.

  • Profile Image

    Answered by deepcreek on August 16, 2012 at 10:57 AM
    Delivered-To: contact.rickmc@gmail.com
     Received: by 10.76.142.70 with SMTP id ru6csp146271oab;
     Thu, 16 Aug 2012 07:51:44 -0700 (PDT)
     Received: by 10.229.106.226 with SMTP id y34mr907614qco.54.1345128703759;
     Thu, 16 Aug 2012 07:51:43 -0700 (PDT)
     Return-Path: <000001392feb24d7-78a32929-aba8-4968-a0ec-63efe80701d4-000000@amazonses.com>
     Received: from b232-182.smtp-out.amazonses.com (b232-182.smtp-out.amazonses.com. [199.127.232.182])
     by mx.google.com with ESMTP id o6si5705627qad.42.2012.08.16.07.51.43;
     Thu, 16 Aug 2012 07:51:43 -0700 (PDT)
     Received-SPF: pass (google.com: domain of 000001392feb24d7-78a32929-aba8-4968-a0ec-63efe80701d4-000000@amazonses.com designates 199.127.232.182 as permitted sender) client-ip=199.127.232.182;
     Authentication-Results: mx.google.com; spf=pass (google.com: domain of 000001392feb24d7-78a32929-aba8-4968-a0ec-63efe80701d4-000000@amazonses.com designates 199.127.232.182 as permitted sender) smtp.mail=000001392feb24d7-78a32929-aba8-4968-a0ec-63efe80701d4-000000@amazonses.com
     Return-Path: 000001392feb24d7-78a32929-aba8-4968-a0ec-63efe80701d4-000000@amazonses.com
     From: test tester <noreply@jotform.com>
     To: contact.rickmc@gmail.com
     Subject: Cloud 10 Rental Inquiry
     MIME-Version: 1.0
     Content-Type: multipart/alternative; boundary="----=_Part_666588_632317121.1345128703193"
     Date: Thu, 16 Aug 2012 14:51:43 +0000
     Message-ID: <000001392feb24d7-78a32929-aba8-4968-a0ec-63efe80701d4-000000@email.amazonses.com>
     X-SES-Outgoing: 199.127.232.182

  • Profile Image
    Chief Technology Officer

    Answered by eee on August 16, 2012 at 11:13 AM

    Hi,

    I made a test submission with subject is "NEWEST", could you please check it's reply-to address ?

    Ertuğrul.

  • Profile Image

    Answered by deepcreek on August 16, 2012 at 11:28 AM

    the emails with subject "NEWEST" do not have a reply-to and if I reply, they want to get sent to: "Please Reply to Thread about Reply-To <noreply@jotform.com>"

    The only one that had a reply-to was the one with subject " New submission: Untitled Form"

  • Profile Image
    Chief Technology Officer

    Answered by eee on August 16, 2012 at 11:33 AM

    Hi,

    Your form is broke down and need to be replaced with cloned one,

    Is that possible for you to chance your FormID on your website with a new one ?

    - Ertuğrul.

  • Profile Image

    Answered by deepcreek on August 16, 2012 at 11:36 AM

    the cloned one worked.  How did the original get broke and how to I make sure that any new form I create doesn't fall into the same trap?

  • Profile Image
    Chief Technology Officer

    Answered by eee on August 16, 2012 at 11:40 AM

    That's not a common situation, 

    I will investigate deeply to find the real problem,

    Thank you for your understanding,

    Kindest regards,

    Ertugrul.

  • Profile Image

    Answered by deepcreek on August 16, 2012 at 03:35 PM

    It's broke again :(

     

    here's how I broke it.  Obviously a bug in the system at jotform.

    I went to the cloned form that was working and did the following:

    1) changed subject to "Cloud 10 rental inquiry"

    2) changed a few cells in the table of form data

    3) went to Reply-to and recipient settings and then changed from address to Email rather than noreply@jotform.  Noticed that made the Reply-To field become hidden and decided no, don't want that so I changed From back to Noreply@jotform which enabled there reply-to.  I then hit save.

     

    Now it's broken again and only replies to Noreply@jotform.  ARRRRGH!!!!

  • Profile Image

    Answered by deepcreek on August 16, 2012 at 06:29 PM

    Guess what.  if you edit your Thank You custom URL, it appears to work but when you use the script, the changed URL is not obeyed, it goes to the old URL.  The Editing and saving seems to be the problem with the Thank You URL and the notification issue.

  • Profile Image
    JotForm Support

    Answered by idarktech on August 16, 2012 at 06:45 PM

    @deepcreek

    Thanks, we appreciate your help about this issue. Would you mind opening a new thread for your other concern? We appreciate if you could create a new thread for your other issue. We'd like to preserve the main topic as it's not yet resolved. And so we'll be able to create a new bug report for our developers incase we can't get that sorted out.

    Thank you for your understanding.

  • Profile Image
    JotForm Support

    Answered by Mike_T on August 16, 2012 at 06:51 PM

    @deepcreek,

    Let me add my two cents.

    2) changed a few cells in the table of form data

    I think that we have a bug with reply-to for Custom Notification Templates. In other words, reply-to works for default Templates only.

    We will take a look into, and let you know once we have any updates.

  • Profile Image

    Answered by deepcreek on August 16, 2012 at 06:59 PM

    I don't think it has to do with default vs custom templates as I can delete the notification email and create a new one and it will work.  If I then go back and edit the notification, it breaks.

  • Profile Image
    Chief Technology Officer

    Answered by eee on August 17, 2012 at 03:46 AM

    Hi,

    I have found out the problem and it has been solved now,

    Thank you for your understanding and patience :)

    Kindest Regards,

    Ertuğrul.