Take Photo Widget: Images are taken at submit time but are not showing in submissions

  • Profile Image
    Diasol
    Asked on July 27, 2017 at 11:46 AM

    Hello,

     

    I did add the Take photo plug in in my form : https://form.jotform.ca/72054936797268

    My problem is that I cannot see the photos in the google sheet or even in the google drive folder. I can see the other datas but no link for the photo file.

    I will use this form for hundreds of entries.

    Thanks for your help.

  • Profile Image
    AIDAN
    Answered on July 27, 2017 at 01:44 PM

    Upon inspection of your form I found that your Take Photo widget field is not set as required, which may explain why your submissions do not contain pictures as the form submitters may have simply skipped it.

    Please consider setting this field as required by right clicking on the field then selecting the "* Require" option as highlighted in this screenshot I created for you:

    I hope this helps. If you need further assistance please let us know. Thank you.

  • Profile Image
    Diasol
    Answered on July 27, 2017 at 02:02 PM

    well, thanks but this is worst : I cannot submit the form anymore. I take a photo, it shows the photo but when I click on submit it shows "this field is required"

  • Profile Image
    Diasol
    Answered on July 27, 2017 at 02:05 PM

    by the way I was testing the form myself, so I was sure I took a photo, and tried several times. I do use the form on an iPhone.

  • Profile Image
    AIDAN
    Answered on July 27, 2017 at 03:44 PM

    First of all please accept my apologies for any inconvenience.

    Thanks to the additional information you provided it's clear now that there is an issue preventing images from showing up in the submissions, as before I assumed you may have received submissions without them, but as you pointed out, you are sure to have taken photos with those submissions.

    I am escalating this so that our developers can look into it. We will be notified of any progress via this thread.

  • Profile Image
    Diasol
    Answered on August 07, 2017 at 11:46 AM

    thanks for the updates, but the problem is still the same : I cannot find the photos anywhere. 

    Moreover, if I mark the photo widget as necessary, I cannot upload the form as it tells me "required field" even if I got a photo. If I don't set it as necessary, it works, I can send the form, but if I can find the other infos as the name etc, I don't have the pics.

  • Profile Image
    AIDAN
    Answered on August 07, 2017 at 01:06 PM

    I will forward your followup to our developers and we will hopefully get back to you on this.

    Apologies for any inconvenience.