Edit submissions: Conditional logic to disable a field is not working for checkbox, radio button and dropdown fields when the submission is edited

  • Profile Image
    marcellobrazil
    Asked on August 03, 2017 at 10:53 AM

    Before I only needed to click once in the Edit Submission in any of my forms. However now when I click for the first time the condition "Disable fields" isnt working but when I click again in the Edit Submission it open a new window with the same URL and the condition "Disable" it is working....thats is strange

  • Profile Image
    BJoanna
    Answered on August 03, 2017 at 01:18 PM

    We had an issue with the conditional logic to disable a field when the submission is edited. It was not working. However, this issue was recently resolved. 

    Please test it again. 

    If the issue still persists on your end, please let us know if you are editing the submissions from the submission page or with the edit link from the email Notification/Autoresponder. 

    Also, provide us ID of the form you have issues with and if possible tell us which fields should be disabled when the submission is edited.

  • Profile Image
    marcellobrazil
    Answered on August 03, 2017 at 01:25 PM

    THANKS!! I tried to talk to many supports and all they said was the conditional was right.

    I edit in the email Notification/Autoresponder.

    The issue persist, sometimes the condition stop to work. I did a few test now the condition wasnt working for field of multiple choice.

    In all my forms Im having this trouble. (flaviafigueiredo)

    PLEASE HELP ME, this condition it is really important and I changed several times my forms trying to solve it

  • Profile Image
    marcellobrazil
    Answered on August 03, 2017 at 01:31 PM

    The fields that should be disable I made the condition. This a bunch of and depends if the person is Buyer or Supplier, Compras or Fornecedor. I can give some example if you need.

    Im confused because everthing was working perfectly, now sometimes it isnt

  • Profile Image
    BJoanna
    Answered on August 03, 2017 at 03:02 PM

    Sorry for the inconvenience this may cause you.

    I made several tests with my demo form and the issue with the conditional logic to disable a field when the submission is edited, was fixed only for input fields. It is still not working for the fields like dropdown, radio button (single choice) and checkbox (multiple choice). 

    On my end it is not working even when I reload the edit link. 

    I will report this issue to our developers and we will inform you via this thread once this issue is resolved.

  • Profile Image
    marcellobrazil
    Answered on August 03, 2017 at 04:52 PM

    Okay, thanks!!

  • Profile Image
    marcellobrazil
    Answered on August 07, 2017 at 08:03 AM

    any status?

  • Profile Image
    BJoanna
    Answered on August 07, 2017 at 11:25 AM

    Unfortunately, this issue is still not resolved. One of our developers is assigned to this ticket and priority is set to important. Once this issue is resolved we will inform you via this thread.

  • Profile Image
    NeilVicente
    Answered on August 08, 2017 at 03:35 AM

    @marcellobrazil

    This should be fixed now. 

    Can you please test on your end and let us know if the issue persists?

    Thanks!

  • Profile Image
    marcellobrazil
    Answered on August 08, 2017 at 07:58 AM

    THANKS, now it is working!

    I think only for the field "upload a file" is not working, can you check please?

  • Profile Image
    BJoanna
    Answered on August 08, 2017 at 09:12 AM

    I was able to replicate the issue with a file upload field. I will inform our developer about it and we will update you via this thread once the issue with a file upload field is resolved. 

  • Profile Image
    NeilVicente
    Answered on August 08, 2017 at 11:48 PM

    Upload file disabling/enabling is now fixed.

    Best,