Take Photo ignores default camera setting.

  • Profile Image
    breadform
    Asked on August 09, 2017 at 02:09 PM

    I had a hard time getting the "Take Photo" widget to work.  I could configure it fine, but it didn't seem to respond to whether the default camera should be front or back.  I tried to adjust it in the settings and on the form to the front camera (back of my phone) and, it kept using the back (selfie) camera.  There's a circular arrow icon on the viewer in the form itself that should allow you to swap from back to front or front to back but that just made the window go black and ask for permission to use the device's camera again.  When I chose allow, it would default to the back (selfie) camera.  Too bad - it would be a nice feature to have in my form.

    If you have any feedback, I'd be happy to try it!

    Thanks,

    Justin

  • Profile Image
    Kevin_G
    Answered on August 09, 2017 at 02:44 PM

    I have tested the widget and I can see it works as expected on my end, for example, I have set the back camera as default on the widget settings: 

    Here is the default camera opened when I loaded the form on my mobile device: 

    I would recommend you to try updating the widget, this way the latest scripts are applied: 

    If the issue persists, please provide us the device details where you replicated the issue, I have used Android and Google Chrome. 

    We will be glad to take another look. 

  • Profile Image
    breadform
    Answered on August 09, 2017 at 02:49 PM

    Thank you for checking it out and responding so quickly!  I'll see if I can get it to work.