Salesforce Integration works when I test it - but not when actual leads come through

  • Profile Image
    ameriform
    Asked on August 21, 2017 at 09:41 AM

    Hello - My salesforce integration works when I authenticate, and then when I test with actual usage on my site (Quote Request)....but when an actual lead came through, it did not work.  Is it possible the authentication time's out?  Please advise....every time I try to test it it works.  But when the most recent actual lead came through, it did not show in Salesforce.  Please advise, thank you.

    Mike

  • Profile Image
    candy
    Answered on August 21, 2017 at 11:08 AM

    Dear Mike,

    We're sorry for the inconvenience you have.

    I have cloned your form named "Request Quote" on my side in order to test Salesforce Integration, disabling Sandbox mode. I have seen that my testing submissions also did not appear in the Leads list of my Salesforce account despite configurations are all correct.

    I have forwarded this issue to our software development team in order to fix the issue. We are going to inform you as soon as the issue will be solved.

    Thank you very much for contacting us.

  • Profile Image
    ameriform
    Answered on August 28, 2017 at 02:51 PM

    Any updates here?  My form is still not working correctly.  My sample request form works, not the quote request.  Please advise, my team needs this working ASAP. 

     

    Best Regards - Mike

  • Profile Image
    aubreybourke
    Answered on August 28, 2017 at 03:58 PM

    I will notify the development team for you. But the development team have to prioritize their requests. And we can not say if or when they will reply.

    What I suggest is you try and remove your salesforce integration and integrate again. That often fixes the problem in similar cases.

    Also please read this guide:

    Mastering SalesForce with JotForm

     

  • Profile Image
    ameriform
    Answered on August 28, 2017 at 05:12 PM

    Thank you - I will try to remove and re-integrated again.  Previous message sounded like it was being worked on by software development.  If I can't get this to work, and I'm too low priority, I will need to shop to another provider of form services. 

    Thanks - Mike

  • Profile Image
    jonathan
    Answered on August 28, 2017 at 07:56 PM

    Please do let us know of the result of the re-integration process. Contact us again anytime if issue persist.

    You are right that there is an attached bug ticket report concerning this thread which was forwarded to the dev team. Currently the ticket report was already assigned to one of our developer.

    The priority for this ticket report was set to as 'Important'.

    The Salesforce integration is an important feature of the form. So I am sure the turn-around  for update will be higher.

    Thanks.