Why is my conditional redirection not working?

  • Profile Image
    MaryGiuliani
    Asked on August 21, 2017 at 03:34 PM

    Hello.

    I"m hoping you can help me determine why my form isn't working.

    I've set the form up so that, depending on the calculated value, the submission will redirect to a specific page.

    However it's not working.

    I previously set up a Support inquiry and got a response saying that the form should now be working but I'm not successfully getting the redirect.

     

    Form is:

    https://form.jotform.us/72236732684158

    Redirect should be :

    http://marygiuliani.net/quiz-results-0-3/

    http://marygiuliani.net/quiz-results-4-6/

    http://marygiuliani.net/quiz-results-7-10/

     

  • Profile Image
    Kevin_G
    Answered on August 21, 2017 at 03:56 PM

    I have cloned your form and noticed the conditions work as expected, for example, if the calculation is 4 you should be redirected to Google, please test my cloned form here: https://form.jotformpro.com/72326374372962 

    Also, I've noticed that you have the "Clear hidden fields" option enabled, I would recommend you to disable such option, this way the Form Calculation's value is not cleared when the submit  button is clicked: 

    Please let us know how it goes. 

  • Profile Image
    MaryGiuliani
    Answered on August 22, 2017 at 11:23 AM

    Thank you for taking the time to look into this for me.

    It's Very Strange and Frustrating!!!

    I can't get the redirect to happen when I publish and use the code on my site.

    I'm using the embed code provided.  I've tried all the various embed code options.

    The correct calculation and the correct redirect happen when I'm testing or completing the actions on Jotform.com however, when I take the provided embed code for, pop-up, iframe, ect. (I've even tested in Dreamweaver, Squarespace, Wordpress , and use it on my website, the redirect won't happen.

    Can you provide any ideas why?

    Here's a screenshot of what happens after submission using the code for "feedback button"...

    (it's the same result with the other types of code provided; action doesn't complete... boo!!@@!@).  

    For now, I'll just use the link https://form.jotform.us/72257012784153 ... The link works, however, I'd really prefer that they don't have to leave the website to get the form to work.

     

  • Profile Image
    Kevin_G
    Answered on August 22, 2017 at 11:47 AM

    Apologies for the inconveniences this may have caused to you. 

    I have just cloned your form and embedded it using the pop-up method, but I failed to replicate the same issue you are experiencing.

    Please test my form on the following link: https://shots.jotform.com/kevin/Content/Samples/1228818/ 

    If the calculation is 0 then you should be redirected to Google.

    This may be a script conflict that does not allow the JotForm form to properly do the redirection, may you please add the form to your webpage again? 

    We will be glad to check it further in order to find why the custom thank you pages are not showing up. 

    Looking forward to your response.