We are getting an error after submitting the form that says the page takes too long to respond

  • Profile Image
    pauljones9005
    Asked on August 28, 2017 at 06:55 PM

    Currently we use the email services to send dispositions to our clients. At this time whenever we try to send any we receive an error message stating it "took too long", and they will not go through. We're unsure how to access that. Thanks!

  • Profile Image
    Kevin_G
    Answered on August 28, 2017 at 09:31 PM

    I have checked the last form you have edited and it seems to be working while using its direct link. 

    It seems that you have embedded your form on a local page, could you please try embedding it using the iFrame code? 

    Please follow the steps on this guide in order to get it: https://www.jotform.com/help/148-Getting-the-form-iFrame-code 

    Also, try embedding the iFrame code only, without the JavaScript part, example: 

    <iframe

            id="JotFormIFrame"

            onload="window.parent.scrollTo(0,0)"

            allowtransparency="true"

            src="https://www.jotform.com/1234567890"

            frameborder="0"

            style="width:100%;

            height:6806px;

            border:none;"

            scrolling="yes">

          </iframe>

    I would also recommend you to provide us with a link from your website that we can check, we will be glad to further take a look on it. 

     

  • Profile Image
    pauljones9005
    Answered on August 29, 2017 at 08:43 AM
    Below is an example of what is happening. The direct link can be found in
    the example. We are unable to send for ANY of our forms. We are currently
    down system wide.
    ...
  • Profile Image
    pauljones9005
    Answered on August 29, 2017 at 08:43 AM
    And we already are using IFrame
    ...
  • Profile Image
    Welvin
    Answered on August 29, 2017 at 09:50 AM

    Would you mind trying the following links?

    https://www.jotformpro.com/form/61177569417970 

    https://www.jotform.com/61177569417970

    https://www.jotform.us/61177569417970

    If any of the above links work for you, please use it as the URL in the iframe embed codes. I understand that this is a bit tedious considering the number of your forms, but your embed codes need to be updated to use the secure form URL.

    Otherwise, let us know so we can forward this case to our backend team for further review. 

    Note that you also need to access this thread to post a screenshot. Email attachment or inline image attachment won't appear on this thread as they are currently not supported. 

    https://www.jotform.com/help/438-How-to-Post-Screenshots-to-Our-Support-Forum 

  • Profile Image
    pauljones9005
    Answered on August 29, 2017 at 10:07 AM

    I tried the first link and it doesnt work. Please send this to your backend team as this has been going on for 15 hours and we need this resolved ASAP

     

  • Profile Image
    Welvin
    Answered on August 29, 2017 at 10:40 AM

    How about the other two? Please let us know if they work or not. This would help us out to determine whether this is a regional problem. 

    I have now submitted this thread to our backend team. If there are updates, you should know it through this thread.

  • Profile Image
    pauljones9005
    Answered on August 29, 2017 at 11:25 AM

    None of them are working.

  • Profile Image
    Welvin
    Answered on August 29, 2017 at 11:55 AM

    Thank you for the update. I've already sent this matter to our backend team. We will keep you updated.

    For the meantime, you may consider checking your network settings such as try changing your DNS to Google Public DNS to see if that will work for you. Also, try clearing your browser cookies and cache. Lastly, try accessing and submitting the form using a different browser. Get back to us with information if they work or not. I'll add them to the report just in case. 

  • Profile Image
     
    Answered on August 29, 2017 at 12:58 PM

    Tried them.  Not working.  What kind of backup do you have?  It has been almost 24 hours now that it has been down.

  • Profile Image
    Welvin
    Answered on August 29, 2017 at 01:15 PM

    Thank you for the update. I have just sent a note to our manager about this ticket. 

    I'm sorry to say, but I found no other workaround on this. The domain change in the form URL worked for the others, but not on your end. The form also worked to my end, so maybe this is specific to your location. We will keep you updated. 

  • Profile Image
    Katie
    Answered on August 29, 2017 at 03:44 PM

    We touched base with out IT Department.  Below are the things they have done:

    Changed our DNS settings to what you suggested

    Whitelisted all your domains

    Restarted our Firewall

    Disabled some security services

     

    Everything has been unsuccessful.  It appears to be working from everywhere except from our location.  I have tried it from my phone and it worked.  I have also had someone try it from their home and it has worked.  It just isn't working from our IP address.  Please let me know any suggestions that you may have.  I need this resolved ASAP.

  • Profile Image
    Mike
    Answered on August 29, 2017 at 05:27 PM

    If you use a dedicated IP address, please provide us with that address so we will be able to whitelist it on our side. However, this will not change anything if our address is blocked from your end (which is probably the case).

    Please also try accessing the next links and let us know if you can open them.

    https://submit.jotformpro.com

    http://submit.jotformpro.com

    Thank you.

  • Profile Image
    Katie
    Answered on August 29, 2017 at 05:40 PM

    Our dedicated IP is 97.80.150.242

    I am unable to access the links.  I am attaching a screenshot of the error messages.

    In reference to your addresses, are there certain ones I need to let our IT dept know about?  I have already told them about the ones we have previously mentioned and sent them this email thread as well.

     

    Thanks.

  • Profile Image
    pauljones9005
    Answered on August 29, 2017 at 05:42 PM

     

  • Profile Image
    Mike
    Answered on August 29, 2017 at 06:52 PM

    The 97.80.150.242 IP address has been added to our whitelist.

    If this does not help, you may need to check with your IT dept why the submit.jotformpro.com address is not opening from your computer/network.

  • Profile Image
    Katie
    Answered on August 29, 2017 at 07:12 PM

    It still isn't working. And they have already added submit.jotform.com to our end as well as others. Can you please provide me a complete possible list of things they need to whitelist?

     

    We currently are not directing ours to submit.jotformpro.com. Is this something we need to do?

  • Profile Image
    Kevin_G
    Answered on August 29, 2017 at 09:01 PM

    I can see this thread has been already escalated to our second level and it's currently assigned to one of our developers, I will ask him for the information you are requesting and I will also ask for any progress on this ticket. 

    We will update you as soon as possible. 

  • Profile Image
    pauljones9005
    Answered on August 29, 2017 at 09:05 PM

    Can it please be escalated even higher? We have been down now for over 30 hours. This is unacceptable and it takes hours to get a response. Is there someone I can physically talk to over the phone?

  • Profile Image
    Mike
    Answered on August 29, 2017 at 10:17 PM

    We do not offer support over the phone. The ticket received the highest priority - urgent.

    We use the submit.jotformpro.com address too, so it should not be blocked on your end. I think that if the address is blocked on your end (e.g. by antivirus, firewall, hosts file, DNS, router, proxy, etc.) this is not likely that our Engineers will be able to help. The issue should be checked by your IT department.

  • Profile Image
    pauljones9005
    Answered on August 29, 2017 at 10:21 PM

    Ok. Please send me a list of everything that needs to be whitelisted on our end so we can double check everything my IT dept did today

  • Profile Image
    Kiran
    Answered on August 30, 2017 at 12:29 AM

    Since you are from the US and having a paid subscription, the possible domains used are jotform.com, jotform.us and jotformpro.com. You may consider adding the following URLs to the whitelist.

    jotformpro.com

    jotform.com

    jotform.us

    submit.jotformpro.com

    submit.jotform.com

    submit.jotform.us

    Also, as I check your first screenshot, the HTML file seems to be accessed from a downloaded local file. Could you confirm if the form is embedded on any of your web pages and trying to access it? If no, please let us know how the form is being accessed which would help us in investigating the issue further.

    Thank you! 

  • Profile Image
    Kiran
    Answered on August 30, 2017 at 12:32 AM

    Also, please confirm if you are having the same issue when the form is accessed using a different browser.

    We will wait for your response. Thank you! 

  • Profile Image
    uygar
    Answered on August 30, 2017 at 01:16 AM

    Hi,

    Sorry for the inconvenience. Your ip was banned by our internal firewall. All your forms should be working now. Pls check again.

  • Profile Image
    pauljones9005
    Answered on August 30, 2017 at 08:50 AM

    Most of them are working now, but there are still several that aren't.  Below are four examples:

     

    Labeled as in Jotform: CCC Main Line

    URL where form is embedded: http://cccscripting.com/scripts/concierge-7067072004.html?highlight=WyJjb25jaWVyZ2UiXQ==

    Direct Link to form: https://www.jotform.com/pauljones9005/ccc-main-line

     

    Labeled as in Jotform: Promenade Center for Dentistry

    URL where form is embedded:http://cccscripting.com/scripts/concierge-8772186810.html?highlight=WyJwcm9tZW5hZGUiXQ==

    Direct Link to form: https://form.jotform.com/60774437420152

     

    Labeled as in Jotform: Designing Smiles Dental - Dr. Judith Mamah

    URL where form is embedded: http://cccscripting.com/scripts/concierge-8772186810.html?highlight=WyJwcm9tZW5hZGUiXQ==

    Direct Link to form: https://form.jotform.com/60565630715152

     

    Labeled as in Jotform: Northalsted Dental Spa

    URL where form is embedded: http://cccscripting.com/scripts/concierge-8775500605

    Direct Link to form: https://form.jotform.com/60077785652161

     

    **I have tried submitting the form from different browsers as well as using the website where they are embedded and using the direct link url provided by Jotform.  I am getting the same error message we received yesterday.  Can you please make sure that everything that was banned from your firewall(s) has effectively been removed?**

  • Profile Image
    Nik_C
    Answered on August 30, 2017 at 10:54 AM

    I tested this form https://submit.jotform.us/submit/42193943372155/ and I was able to submit it.

    I tried to access the websites where the form is embedded but none worked:

    Could you please check the URLs again?

    Thank you!

  • Profile Image
    Katie
    Answered on August 30, 2017 at 11:01 AM

    The URLs where there are embedded are correct.  Your IP address has to be whitelisted for you to see them.  They are private to our organization.  THE ISSUE ISN'T WHETHER OR NOT YOUR ORGANIZATION CAN SUBMIT THE FORM (WHICH ISN'T THE PROBLEM).  THE ISSUE IS WHETHER OR NOT WE CAN.  Jotform had our IP banned from their firewall.  After unbanning it, 95% or our forms worked.  I am now worried about the other 5% that are not working.  Once again, can you please read over the entire thread before responding and see if everything that was banned has effectively been fixed?  Every single form we had was working until this issue that started on Monday, 8/28/17 at ~ 6pm EST.  I have now had my IT department try everything on our end.  It is obviously an issue that is occurring on your end and we need it fixed.  This ticket was supposedly marked as urgent and sent to the second level of support.  I need this fixed as soon as possible.

  • Profile Image
    uygar
    Answered on August 30, 2017 at 11:21 AM

    Sorry for the late response. All your forms back to normal. Pls check again. We ensure you to this will never happen again. Sorry for the inconvenience.

  • Profile Image
    Katie
    Answered on August 30, 2017 at 11:29 AM

    I would like to know what happened in the first place.  Can I please get an explanation?

  • Profile Image
    uygar
    Answered on August 30, 2017 at 11:38 AM

    Hi,

    We have several submission servers. Some of them were not to get the firewall update. We solved that glitch and servers firewalls back to normal.