Postal Code not working on Square payment submission

  • Profile Image
    elliotportions
    Asked on September 11, 2017 at 11:08 AM

    Hello Support!

    I'm in Canada, and need to accept payment through my Jotform using Square. Initially, there was a token error code when I would submit, but I figured out the issue by searching through support. The new issue I'm having, however, has not been solved publicly as yet. 

    When attempting to pay using the Square widget, there is a postal code error that doesn't allow the payment to go through. I've tried with 2 different cards from two different people, used every possible postal code I had ever associated with the card, and the issue persists.

    I tried deleting the Square widget and bringing it back (which originally fixed the token issue), but now this issue doesn't seem to have a listed fix on your support pages despite one of the instances showing as resolved. 

    Please help! I need a fix to this as soon as possible.

    Best,

    Elliot

  • Profile Image
    Chriistian
    Answered on September 11, 2017 at 11:50 AM

    @Elliot, that was a rare issue with Square payment integration. Have you tried confirming with your bank the correct postal code for your card? If not yet, please do so so we can be sure you are indeed entering the correct code.

  • Profile Image
    elliotportions
    Answered on September 11, 2017 at 02:54 PM

    Hey Christian,

    It turns out the postal code I had at the bank was incorrect (but worked with other websites somehow). Manged to make it work using a different card, so I would consider this to be resolved in the meantime. Thanks for your prompt response!

    Elliot