Take Photo/File Upload not working on iPhone

  • Profile Image
    tylerport
    Asked on September 12, 2017 at 10:59 PM

    I have the Take Photo and File Upload widget on my form. Unfortunately, when I use this form on my iphone and it launches my camera, there is only a black screen. In my native iPhone camera app, there is no issue whatsoever. 

    My goal is to use conditional logic to allow users to either use the file upload option, or take a photo. Depending what they choose, either the Take Photo widget or the File Upload widget will open. 

  • Profile Image
    BJoanna
    Answered on September 13, 2017 at 02:35 AM

    I do not have an iPhone, so I asked one of my colleagues to test your form, but he was not able to replicate the issue you reported. Take a Photo widget is working properly. The front and back camera is working. 

    Please test your form again. You can also try to use some other browser and if possible test the form on some other device. 

    If the form is embedded, please provide us the webpage URL so that we can test the form there. 

  • Profile Image
    tylerport
    Answered on September 13, 2017 at 10:43 AM
    I was using chrome. This needs to work on google chrome
    Sent from my iPhone
    ...
  • Profile Image
    BJoanna
    Answered on September 13, 2017 at 12:26 PM

    I asked my colleage and he told me that he was using Google Chrome. 

    Is the form maybe embedded to a website? If so, please provide us the website URL, so that we can test the form there. 

  • Profile Image
    tylerport
    Answered on September 13, 2017 at 05:43 PM
    No i am using the direct link on jotform. Please attempt to use an iPhone 7 and chrome or a 7 plus
    Sent from my iPhone
    ...
  • Profile Image
    Kevin_G
    Answered on September 13, 2017 at 07:36 PM

    Unfortunately, I do not have an iPhone to test this form, I will ask my colleague which device she was  using, I would also recommend you to please test using a different device in order to know if the form works. 

  • Profile Image
    BJoanna
    Answered on September 14, 2017 at 01:52 AM

    My colleague was using iPhone 7. The latest iOS version 10.3.3 on Chrome 61.0.3163.73. 

    Which version of iOS and Chrome are you using? Please update it to the latest version and try again. You can also try to clear your browser data. In the upper right corner click on three dots-settings-privacy-clear browsing data.

    Also if possible test your form on some other iPhone.