Requirements not working

  • Profile Image
    ericahaller
    Asked on September 13, 2017 at 02:48 PM

    We have the appointment slots widget set to be required to submit and have already had two people pay and submit without the form.  There are a lot of people who have been sent this link so we need to get this fixed pretty quickly.

     
  • Profile Image
    ericahaller
    Answered on September 13, 2017 at 02:52 PM

    Hello??

  • Profile Image
    EltonCris
    Answered on September 13, 2017 at 05:33 PM

    I have replied your first thread https://www.jotform.com/answers/1246857. My colleague has also responded the other thread https://www.jotform.com/answers/1246828.

    I think I got what you mean now. However, upon checking your last edited form (72264894640968), the appointment slot is not required.

    This makes it possible for the users to skip this question.

    Or perhaps you are referring to a different form? 

    Please stick to this thread only if you have more questions. This makes it easier for us to provide you assistance without jumping to different threads.

    Thanks for your understanding. 

  • Profile Image
    ericahaller
    Answered on September 14, 2017 at 12:32 PM

    Hi,  At first I had each date properties selected to be "Required: YES" and then used conditional logic to hide and show the forms.  That ended up not working so I made more conditional logic that says if the date is picked, a time needs to be selected and it seems to be working now.  I just wanted to confirm that this is an appropriate solution and isn't going to lead to any new problems.  Thanks.

  • Profile Image
    EltonCris
    Answered on September 14, 2017 at 01:43 PM

    That's actually a good solution.

    We are also glad that it is working now.

    Cheers!