What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Save function error

    Asked by Char on August 30, 2012 at 11:53 AM

    > 1) Our company is utilizing jotform to collect annual report information from employees who work all over the world. We have two staff (one in S America the other in Asia) who have started their report and here is what is occuring:

    > ASIA: I started to fill this out, clicked "save and continue" at the

    > end of each section, yet when I try to access it again, I keep getting

    > a blank form S AMERICA: I've filled this form out two different times

    > and each time when I return to continue I'm not finding any of the information that should have been saved.

    > I'm hitting save and continue after each page is filled out.

    > Please advise... I was deep into the forms and lost connection.... I

    > so hope I don't have to start over for the third time.

    > jotforms response: You can return to your form at any time by visiting

    > http://jotform.us/form/22204413662140?session=yfckimbeck@mac.com

    > Here is our link: http://form.jotform.us/form/22205534294146

    > 2) Additionally, jotform is not notifying our generic email address (worldinfo@yfc.net) with each completion.  We have received a few, however have had to go into jotform to pull several others.

    Page URL:
    http://form.jotform.us/form/22205534294146

  • Profile Image
    JotForm Founder

    Answered by aytekin on August 30, 2012 at 02:10 PM

    We had a database replication lag that caused this problem. It should be resolved now. If it continues please let me know.