Form suddenly acting strange on several fronts

  • Profile Image
    tamsyn
    Asked on September 21, 2017 at 01:11 PM

    Hi JotForm Staff,

    I recently making a few basic edits to my form ("PFI Annual Conference Sponsorship Options" -- https://www.jotform.com/build/72156817603154), and all of a sudden several things about the form are acting strange and not working properly.

    The edits I made when this first started occurred yesterday afternoon (about 4:45 p.m. Central). I deleted the progress bar widget, added a simply page skip condition and a bit of clarifying text in a field label -- nothing that should have caused major issues.

    All of a sudden, when previewing my form, the only page that showed up was the last Payment page.

    So this morning, I thought it might be related to my having deleted the Progress Bar widget, for some reason. I checked my conditions to make sure field names hadn't shifted and thrown them off.

    They looked fine.

    So I looked back in my revision history and decided to revert back to the version of my form just before I deleted the Progress Bar widget.

    That reversion seems to have caused a cascade of bizarre issues:

    -- my organizational logo disappeared (I readded it, but it's sometimes showing up, sometimes not)

    -- the button stylings have disappeared and reverted to standard clear (I didn't touch button styles)

    -- button sizes in some cases (the blue button on page 3) have changed and shrunk

    -- the background color of my form disappeared

    -- subhead styles disappeared (they used to be red; now they've turned brown)

    -- other custom field sizings and widths have shifted

    -- the Form Preview toggle button is not working ... it just spins and spins for minutes on end. (I tried opening my form in a different browser, Firefox instead of Chrome, to test if it was a cache issue -- it still doesn't work).

    -- The Revision History is now doing the same thing -- just spinning and spinning, not opening (I don't think it's our internet, because I can open other pages).

    -- Some conditions aren't working -- though I can't say for sure if that's related to whatever bizarre thing is going on because I did add one but couldn't test it.

    -- a weird message about some issue with the Square integration popped up.

    ...............

    At any rate, we're approaching launch time for this form, and these problems are mystifying -- and taking the form backwards instead of forwards! It's like the form is breaking down in all sorts of places.

    Please help me figure out what's going on here! And if you're able to restore my form to how it was yesterday afternoon, that would be fantastic (because it's not working for me to try to do that)!

    Thanks so much for your help,

    tamsyn

  • Profile Image
    ashwin_d
    Answered on September 21, 2017 at 02:36 PM

    I'm sorry for the trouble caused to you. 

    Can you please let us know that which revision history is the one which you want to revert too? I did check the last revision of yesterday and the current version but could not locate any difference other than the hover color of the buttons. Please check the screenshot below:


    Please confirm which is the correct revision which you want to revert to and we will try to revert it from our end. 

    We will wait for your response. 

  • Profile Image
    tamsyn
    Answered on September 22, 2017 at 12:16 PM

    Hi Ashwin -- I finally was able to get into the revision history and reverted back, which seemed to halt the mysterious erratic behavior that was suddenly happening.

    I wonder if there's a glitch in JotForm's Revert function ... ?

    The form appears to be working now (I did have to re-do several things) -- but I still think something weird is going on.

    If I go into the advanced form designer, a lot of my formatting is stripped away.

    For instance, the color of my buttons looks entirely different in Advanced Form Designer than in my form itself ... the background color is gone ... etc.

    I don't want to risk making any tweaks in there (for instance, to update the style of the E-Level Subtotal field so the font is blue), since I'm concerned that all those weird style discrepancies will be saved back into my form.

    We'll be launching this form live today -- but if you have any possible explanations into what went wrong (a JotForm server issue? Glitch from some form field or condition? I did find a couple of conditions that were improperly set up -- though they had been working before, so I don't know if that was my fault somehow or if the form's erratic behavior caused it).

    This is a hard one to troubleshoot, probably, because what you see now in my form does not reflect at all how bizarrely it was acting yesterday.

    Thanks for your response!

    tamsyn

  • Profile Image
    ashwin_d
    Answered on September 22, 2017 at 01:16 PM

    I am glad to know that you were able to revert back your form to earlier working version. 

    Since no other user have reported similar issue, I do not believe there was any technical glitch at the server level which can cause this issue. I would like to request you to please ensure that you are not logged in to your JotForm account from two different system / browser and loaded this form in editor to avoid saving the older version of form accidentally.

    I would also suggest you to clone your existing working version of your form that will always ensure that you have backup of acceptable form version. The following guide should help you in form cloning:  https://www.jotform.com/help/27-How-to-Clone-an-Existing-Form-from-Your-Account


  • Profile Image
    tamsyn
    Answered on September 22, 2017 at 03:24 PM

    Hi Ashwin,

    Good tips on all fronts! It hadn't occurred to me about over-saving when I logged in from another browser to test.

    That wouldn't have resulted in all the erratic behavior I experienced, however, as I only logged into the second browser in response to what I was noticing.

    But it might have accounted for a couple of minor updates I had to re-do.

    And a wise suggestion to clone my form -- especially for major efforts like this one!

    Hopefully the weirdness was a one-off -- and thanks for your replies!

    tamsyn

  • Profile Image
    Kevin_G
    Answered on September 22, 2017 at 04:24 PM

    Please note that the changes are automatically saved so might be that a conflict happened while the form was saving on both browsers, as you had two active sessions. 

    As suggested by my colleague, using the revision history and reverting to a working version should be the easiest way to fix any issue with the form. 

    Please if you notice the issue happens to you again, let us know, we will be glad to further investigate it.