Inventory Widget: not showing the correct available items.

  • Profile Image
    vtiportal
    Asked on September 25, 2017 at 12:44 PM

    See attached. How do I show none left on my inventory widget? I had my quantity available as 0, but it still showed 1 left.
  • Profile Image
    BDAVID
    Answered on September 25, 2017 at 01:57 PM

    Try clicking on the "update widget" button:

  • Profile Image
    vtiportal
    Answered on September 25, 2017 at 04:23 PM

    As with the other widgets that have inventory numbers, I did, many times. It still showed 1 left.

  • Profile Image
    BDAVID
    Answered on September 25, 2017 at 04:36 PM

    Thanks for confirming, I have reported this issue to our back-end team. You will be notified via this thread when it gets fixed.

  • Profile Image
    vtiportal
    Answered on September 27, 2017 at 11:33 PM

    I've noticed that some of your Jotform customers are able to insert "Out of Stock" or "Sold Out" when there's none left. Why can't I do that? I can live with "Out of Stock", "none left", or "0 left".

    Please advise ASAP as the forms are live and being used.

  • Profile Image
    Nik_C
    Answered on September 28, 2017 at 01:36 AM

    I noticed that the counter is off for 1. So you could insert -1 manually in available quantity:

    That will put "none" in that field:

    What you could do as well, until this issue is fixed, is to hide the widget temporarily since it is not available so your users can not select it:

    Let us know if that could work for you.

    Thank you!


  • Profile Image
    vtiportal
    Answered on September 28, 2017 at 09:58 AM

    I had to put this code in to get "none left" to display:

    .items-left.none-left{display:-1;}
    label.line-through:after{content:”none left”;}

    Why does it have to be "-1"? Why won't "0" work? By the time it's -1, it's already one order too many.


  • Profile Image
    Nik_C
    Answered on September 28, 2017 at 11:12 AM

    There is an issue with how the remaining quantity is showing and this ticket is already escalated to our backend team.

    I just provided you that solution if you need to mark certain fields as none. Assuming they weren't showing properly and you want to set them manually

    I would say that with CSS you did a similar thing since you manually set the content to "none left".

    Anyhow, we would have to wait for a response from our backend team regarding a fix. For the time being, you could manually correct the remaining quantities so you don't have discrepancies in your reports.

    We're sorry for this inconvenience.

    Thank you.

  • Profile Image
    vtiportal
    Answered on September 28, 2017 at 12:10 PM

    See attached 4 screenshots. There's another glitch:

    When I updated a few inventory widgets, the auto-responder email and the email notification did not update accordingly. Despite update email turned on for both auto-responder and email notification. The updated widgets showed the copy of the previous widget.

    So I tried recreating new widgets from scratch. Now the new widgets don't even show up on the email notifications. Despite update email turned on.

    Please fix as soon as you can, or provide me with a solution.


  • Profile Image
    Nik_C
    Answered on September 28, 2017 at 01:39 PM

    I checked all your widgets, their labels and their field names and only what I found is this two:

    The labels are not showing in the email, are you referring to those?

    Did you update other fields (that were wrong) manually?

    The field names are correct for all other fields and they are matching the email Notifier.

  • Profile Image
    vtiportal
    Answered on September 28, 2017 at 01:49 PM

    Yes, the 2 that you have marked are the the latest widgets I have added from scratch.

    The other 2 widgets that I have updated are:

    NaturalVue® Multifocal Rebate

    NaturalVue® Sphere Rebate

    Please note that I have updated from "Rebates" to "Rebate". The email notifications should be automatically updated too, but they are not

    .
  • Profile Image
    BDAVID
    Answered on September 28, 2017 at 02:14 PM

    We will handle this new issue regarding to email notifications not updating, in a separate thread in order to avoid confusion: https://www.jotform.com/answers/1260448 

  • Profile Image
    vtiportal
    Answered on September 28, 2017 at 07:10 PM

    Now that we're handling the email notifications in a separate thread, can we move back to the "0 left" or "none left" issue?

    Please  let me know once you have fixed the problem. Thanks

    .
  • Profile Image
    BDAVID
    Answered on September 28, 2017 at 08:29 PM

    Your inquiry about how to change the label for when there is zero item left, will be handled in the following thread: https://www.jotform.com/answers/1260804