We've got errors uploading files and strange behaviour on the screen

  • Profile Image
    Zabco
    Asked on September 28, 2017 at 11:55 AM

    Good morning,


    Any users have got errors uploading files from the form. The error message is "Upload error".

    for some of them the screen is climbing and they can't fill fields...

    They work on Mac or Windows, with IE or Safari or Chrome... 

    I work on Mac, with Safari or with Firfox and it's ok.


    I don't know why the users have errors...



  • Profile Image
    BJoanna
    Answered on September 28, 2017 at 01:32 PM

    I tested your embedded form, and I was able to replicate the second issue. The form starts jumping when the file is uploaded.

    You embedded your form with the script code and most likely there are some script conflicts between your webpage scripts and the form script. Please re-embed your with the iFrame code to see if that will resolve the issue. Inside of this guide, you can find how to get the iFrame code of your form:

    Getting the Form iFrame Code

    Hope this helps to solve the issue.

  • Profile Image
    Zabco
    Answered on September 29, 2017 at 03:25 AM

    thanks for your answer. I'll test your solution for the screen behaviour.

    For the second and most important issue, a user tested the form out of the webpage (https://form.jotformeu.com/72401703704345) and he's got the same error uploading files.

    Do you think that this is due to OS version or browsers version ? or a missing pluggin ?

    The form is ok for 50% of users and is wrong for the others...

  • Profile Image
    BJoanna
    Answered on September 29, 2017 at 03:57 AM

    I successfully submitted your standalone form. The form is also working properly on iPhone 7 in Safari. Which device and browser are using the users that reported this issue? Also, when is the upload error message shown? When they try to upload a file or when they try to submit the form? Can you please provide us a screenshot of the error message? 

    Also please note that the File Types of all upload field on your form is set to jpg, pdf. IF your users are trying to upload a different file extension the will not be able to do it, an error message will be shown. 

  • Profile Image
    Zabco
    Answered on September 29, 2017 at 09:35 AM

    users use :

    --> Windows 10 with Firefox

    --> Mac with Safari

    ...

    The error comes (see screenshot) :

    - uploading one of the files

    - or when submitting the form



    Users who had errors send me files by mail.

    Il felt the form with the same files (.jpg or .pdf), and no errors... I don't understand where the bug is !


  • Profile Image
    Kevin_G
    Answered on September 29, 2017 at 10:51 AM

    I have been testing with both browsers and I'm unable to replicate the issue, it seems to be working as expected as per my tests. Please see the screen-cast below: 

    I would recommend you to check that the file name does not include any space or special character, also make sure that the file you're trying to upload in under the allowed max size on your form. 

    As per your reply above, it seems  like you tried to upload some screenshots about the error, unfortunately they did not reach this thread. Please re-upload them by following this guide: https://www.jotform.com/help/438-How-to-Post-Screenshots-to-Our-Support-Forum 

    We will wait for your response. 

  • Profile Image
    Zabco
    Answered on September 29, 2017 at 11:31 AM

    I've checked the name's file, but they seem to be ok.

    The file size is ok too.


  • Profile Image
    Kevin_G
    Answered on September 29, 2017 at 12:10 PM

    I have just tested your form and it seems to be still working on my end, please see this screenshot: 

    May you please test your form while connected to a different network? 

    This may be a connection error where the file cannot be uploaded. You may also test the form using incognito mode. 

    Please also test your form using the direct link to see if the same issue happens, this guide will help you getting it: https://www.jotform.com/help/401-Where-to-Find-My-Form-URL 

    Looking forward to your response. 

  • Profile Image
    Zabco
    Answered on September 29, 2017 at 03:34 PM

    We already tested with the direct link but the error is the same.

    This form is in production, so it has been used by different networks : some submissions are ok, and some feld on error.


    I get the same error (upload error) this evening, using Safari on my Mac.

    I've tested, with the same files, on Firefox on my Mac and it has worked !


  • Profile Image
    Kevin_G
    Answered on September 29, 2017 at 04:05 PM

    It's a bit hard to investigate the issue on our end since we cannot replicate the issue on our end. 

    May be possible that you provide us a report from the web console? 

    This guide will help you getting it: https://www.jotform.com/help/453-How-to-get-a-console-report-from-most-common-browsers 

    May we also get the files you were testing with? 

    If so, please send the file to us at support@jotform.com we will be glad to test this on our end, please also include this thread ID on the subject: 1260261. 


  • Profile Image
    ben@spadegardens.com
    Answered on September 29, 2017 at 04:23 PM

    Uploading to your support is failing and doing weird things
  • Profile Image
    Kevin_G
    Answered on September 29, 2017 at 05:15 PM

    Ben, 

    Since your question is not related to this thread, I've moved it to a different one, we will help you as soon as possible here: https://www.jotform.com/answers/1261629