Submit button on my form is not working

  • Profile Image
    lorielove
    Asked on September 29, 2017 at 08:56 PM

    My submit button isn't working for some reason. It *was* working but no longer does. Help!

  • Profile Image
    Kiran
    Answered on September 29, 2017 at 11:05 PM

    I have tried submitting the form and was able to submit it without any issue. The thank you message is displayed normally at my end. 

    Are you still experiencing any issue with the form? If so, please let us know if the form is embedded on any of your web pages and experiencing the issue on any specific browser.

    Please check and let us know if you need any further assistance. We will be happy to assist. 

  • Profile Image
    lorielove
    Answered on September 30, 2017 at 12:42 AM

    It's being inconsistent then. It worked for me when I first tried it but then a client had trouble and I had to email her a pdf version. I then tried it again and had the same issue she did, which was that clicking the submit button did nothing. There was no reaction at all as though the button didn't know it was being clicked.

  • Profile Image
    jonathan
    Answered on September 30, 2017 at 01:27 AM

    I test submitted your form but I also could not reproduce the issue. The form successfully submitted and I was able to see the Thank You page.

    I reviewed the form and I noted that it is a very long form with a lot of pages(22).

    What I suggest you do also is to enable the Autofill feature on the form to avoid the respondents loosing data in cause the browser timed out while the user was still completing the long form. Set the Continue Forms Later to enabled to turn ON Autofill.