My form keeps coming up with a "form error" and does not let my customers submit the form

  • Profile Image
    mi_designs
    Asked on September 30, 2017 at 04:34 PM

    Whenever users click submit (renamed "Quote Me"), they get a form error after filling out every aspect of the form.

    There is no other indication as to what the issue could be from my end. Am I missing something> Please help

     
  • Profile Image
    Mike
    Answered on September 30, 2017 at 08:52 PM

    Thank you for contacting us.

    Have you managed to fix the issue? I am able to submit your form at the moment.

    If the issue still persists, please let us know.

  • Profile Image
    mi_designs
    Answered on September 30, 2017 at 09:43 PM

    I did fix it, yes. Unfortunately I fixed it by removing all the required fields, so if the customer decides not to fill out a mandatory field, they can just move on.
    Not ideal, but at least they can submit the form now
    By the way, Do i get those 2 test submissions you did back for the month?
    Many thanks.
    Regards,
    [cid:589b187088700f000007f04c]
    ...
  • Profile Image
    Kevin_G
    Answered on September 30, 2017 at 11:04 PM

    I cloned your form on my end and set the fields as required, please test  it out here: https://form.jotformpro.com/72728654257971 

    As far as I can see it allows me to submit it. 

    May you please try setting up the fields on your form as required? 

    If the issue persists, please provide us a screenshot about it, this guide will help you uploading it: https://www.jotform.com/help/438-How-to-Post-Screenshots-to-Our-Support-Forum