Calculation values: Passing values to another form causes URL encoding issue

  • Profile Image
    aipp
    Asked on October 02, 2017 at 03:45 AM

    Hi, 


    So i have made 2 forms, called "Shell1","Shell2".

    the reason for those two forms, is that i had to divide my main form since it had gotten too LAGGY for users with slower devices. 

    Anyway, I was keeping it fairly simple. I send data from Shell1 to Shell2 using the thank you website.

    the issue is that SOME params get a space"%20" after the data. which causes issues for me

    Shell1 Form: https://form.jotform.me/72515830875462

    Shell2 Form:   https://form.jotform.me/72526199375467

    Help me please. Thank you

  • Profile Image
    candy
    Answered on October 02, 2017 at 08:03 AM

    We are sorry for the inconvenience you have.

    If you have spaces in the fields, this could cause this issue. URL encoding normally replaces a space with a plus (+) sign or with %20.

    I have cloned both of your forms on my side in order to test. I couldn't see any issue and couldn't reproduce the issue you have mentioned. I have entered my email address with space as seen below:

    I couldn't see any issue with the prepopulated fields on the second form as seen the example below:

    I have seen that the link includes "%20" as you can find it: https://form.jotformpro.com/72743638823969?whoHas226=Agent:%20Aus%20Education%20Executive%20Search%20(AEES)&agent2249=&email86=cicek@jotform.com&whatIs236=Less%20than%20IELTS%204.0%20average%20(or%20equivalent)&visaCalculation=V1&industryCalculation=&uniqueid=FVTKTZ4-02/10/2017-&agentDiscount1=1%20%C2%A0%20%C2%A0%20%C2%A0%20%C2%A0%20%C2%A0%20%C2%A0&agentDiscount2=0%20%C2%A0%20%C2%A0%20%C2%A0%20%C2%A0%20%C2%A0%20%C2%A0&paidto=YES&agentsEmail227=&invoiceEmail=cicek@jotform.com 

    However, I never see a "%20" in the prepopulated fields. For detailed information, you can check the following guides: 

    https://www.jotform.com/help/164-Pass-Value-to-Another-Form-with-URL-Encoding

    https://www.jotform.com/help/71-Prepopulating-Fields-to-Your-JotForm-via-URL-Parameters  

    Could you please tell us exactly which fields do you have this problem? So that, we can investigate the problem further.

    Thank you.

  • Profile Image
    aipp
    Answered on October 02, 2017 at 08:21 AM

    HI,

    In the link you have sent me one parameter like "industryCalculation" is empty. 

    but when I fill the form I get this link:

    http://www.aipptraining.com.au/aipp-professional-internship-program-enrolment-form-test-section-2?whoHas226=AIPP&agent2249=&email86=test7854@test.com&whatIs236=Native%20/%20Mother%20Tongue&visaCalculation=V1&industryCalculation=I1g%20%C2%A0%20%C2%A0%20%C2%A0%20%C2%A0%20%C2%A0%20%C2%A0%20%C2%A0&uniqueid=MGW3OVL-02/10/2017-&agentDiscount1=1%20%C2%A0%20%C2%A0%20%C2%A0%20%C2%A0%20%C2%A0%20%C2%A0&agentDiscount2=0%20%C2%A0%20%C2%A0%20%C2%A0%20%C2%A0%20%C2%A0%20%C2%A0&paidto=YES&agentsEmail227=&invoiceEmail=test7854@test.com


    where:

    industryCalculation=I1g%20%C2%A0%20%C2%A0%20%C2%A0%20%C2%A0%20%C2%A0%20%C2%A0%20%C2%A0

    my question is, how do i get rid of all of these extra spaces?

  • Profile Image
    candy
    Answered on October 02, 2017 at 10:58 AM

    Hello again, 

    I have checked your form again according to your description and seen the issue in the Industry Calculation field as seen below:

    As you might see, there comes a lot of spaces, indeed. The error occurs while copying the calculation values from the Industry drop-down field. 

    As far as I checked, when you calculate Industry field, you have multiplied the field with zero and added the industry field. I have changed this condition and just copied the industry field and seen that the issue still persists. It seems to me that this is an encoding error. 

    I have forwarded this issue to our software development team in order to investigate the issue regarding where those empty characters come from. 

    We are going to inform you as soon as the issue will be fixed. 

    Thank you very much for reporting us. 

  • Profile Image
    Helen
    Answered on October 03, 2017 at 07:56 AM

    Hello @aipp,

    First of all, thank you for contacting us.

    Your issue has been fixed now. Please check it again and if you have still a problem, feel free to contact us.

    Thank you,

  • Profile Image
    aipp
    Answered on October 10, 2017 at 08:10 AM

    I dont see the issue anymore, Thank you for fixing it. I actually realised that this issue was on some of my other forms before. I hope this fixed all of them.

  • Profile Image
    Helen
    Answered on October 10, 2017 at 08:18 AM

    Hello @aipp,

    If you have still issue on your other forms, please follow these steps:

    1. Go to a field that you have trouble with calculation values.

    2. Make some little changes on one of the calculation value. When it was saved, the other all calculation values will be fixed in the related field.

    Please do these steps for your fields that have broken calculation values.

    Thank you,