Required field function is not working

  • Profile Image
    mcortez
    Asked on October 02, 2017 at 11:20 AM
    I'm having an issue with one of the formshttps://form.jotform.com/11745211310
    when I publish it, the condition required field doesn't work
    http://cfdsmiles.com/makeapptnow.html
    when I check the settings, it's fine but once embed in page, it's not working properlyThanks in advance,Marjorie Cortez
  • Profile Image
    Jan
    Answered on October 02, 2017 at 11:50 AM

    I checked your form and I did not see any Enable/Required field condition.

    May I ask what field or what condition are you referring to? Also, please delete the conditions that have an error missing fields.

    We will wait for your response. Thank you.

  • Profile Image
    mcortez
    Answered on October 02, 2017 at 01:43 PM
    Hi,The first page, first field is required *You can move to the second page without completing the required fieldsI also have the form in Spanish and it's working finehttp://www.cfdsmiles.com/hacercita.html And yes, I will remove the fields with errors ThanksMarjorie Cortez
    ...
  • Profile Image
    Jan
    Answered on October 02, 2017 at 02:05 PM

    Unfortunately, I was not able to replicate the issue you are referring to. I opened your webpage in Google Chrome and in Mozilla Firefox. I was not able to go to Page 2 without completing the required fields. Here's a screen capture:

    Are you experiencing the same problem if you open the form's direct link (http://www.jotform.com/form/11761639249)?

    I suggest you re-embed the form using the iFrame method to prevent script conflicts. Here's a guide: Getting-the-Form-iFrame-Code.

    Hope that helps. Thank you.

  • Profile Image
    mcortez
    Answered on October 02, 2017 at 02:43 PM
    Hi,The screen caption shows the Spanish versionAs I said, the issue is with the English version only, but when you open it with this link 
    http://www.cfdsmiles.com/makeapptnow.html 
    Not with the jotform link
    Really weird :(
    Thanks.
    MC
    ...
  • Profile Image
    Jan
    Answered on October 02, 2017 at 03:14 PM

    Just to be clear, you are referring to this form (https://www.jotform.com/form/11745211310) which is embedded on this webpage (http://www.cfdsmiles.com/makeapptnow.html), correct?

    The required function is working fine if you open the form using the direct link.


    However, the required function is not working properly on the webpage where the form is embedded.

    The solution is to re-embed the form using the iFrame method. This will prevent script conflicts between the form and the webpage. Here's a guide: https://www.jotform.com/help/148-Getting-the-Form-iFrame-Code.

    Hope that helps. Thank you.

  • Profile Image
    mcortez
    Answered on October 02, 2017 at 04:43 PM
    Thank you so much,I will and let you know MC
    ...